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Preface
When it comes to designing in Photoshop, there is a myriad of ways one 
could use to achieve a certain result. Designers use techniques they are 
most confident as well as comfortable with, which is great because it’s 
always useful to peek into the workflow of our colleagues and learn new 
design approaches. Creating great artwork without intimately knowing your 
tools is certainly possible, but the more you know, the more likely you are 
to work faster and with greater confidence.

This eBook contains 11 articles that cover useful techniques and tricks from 
experts such as retouching, cloning, compositing, obscure Photoshop time-
savers and designing for iPhone. You may know some of them, but 
hopefully not all of them.

The articles have been published on Smashing Magazine in 2010 and 2011 
and they have been carefully edited and prepared for this eBook.

We hope that you will find this eBook useful and valuable. We are looking 
forward to your feedback on Twitter and via email.

— Thomas Burkert, Smashing eBook Editor
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Mastering Photoshop: Noise, Textures, 
Gradients and Rounded Rectangles
Marc Edwards

Often, it’s the little details that turn a good layout into a great design; 
details such as subtle textures, shading and smooth shapes. Photoshop 
contains a vast array of tools for embellishing a design, but choosing the 
right one isn’t always easy. Being the obsessive-compulsives that we are, 
we’ve conducted a huge range of experiments to determine the benefits 
and disadvantages of each technique. Here, then, is an obsessive-
compulsive’s guide to some frequently used tools and techniques for Web 
and UI design in Photoshop.

Noise and Textures

Subtle noise or texture on UI elements can look great, but what’s the best 
way to add it? Our goal is to find the best method that maintains quality 
when scaled but that is also easy to implement and edit. To find out which 
is best, we’ll judge each method using the following criteria:

• Number of layers used: fewer is better.

• Ability to scale: if the document is resized, will the effect maintain its 
quality?

• Can the noise be on top of the Color and Gradient layer styles?

• Can the method be used with any texture, not just noise?

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 5



1. Bitmap Layer With Noise

Probably the most obvious method for adding texture to a shape is to 
create a normal bitmap layer, fill it with a color, select Filter → Noise → 
Add Noise, then apply a mask or Vector Mask to match the element 
you’re adding noise to.

Using a high amount of noise, setting the layer blending mode to 
Luminosity and reducing the opacity will yield the most control over the 
noise with the least disturbance to the underlying layers. A noise setting of 
48% gives a high dynamic range without clipping the noise. (Clipping 
results in higher contrast, which might not be desirable.)
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• Layers: 2

• Scales: No, texture will have to be recreated if the document is scaled

• Works with Color and Gradient layer styles: Yes

• Works with any texture: Yes

2. Inner Glow Layer Style

Adding an Inner Glow layer style with the source set to center and the size 
to 0 will let you use the noise slider to add texture to any layer. It’s a good 
solution, provided you’re not already using the Glow layer style for 
something else. The noise is added above the Color, Gradient and Pattern 
layer styles, which is great.

Unfortunately, the noise can only lighten or darken the underlying 
elements. The previous bitmap layer method can add highlights and shade 
at once while maintaining the average luminosity, and it looks far better in 
my opinion.

• Layers: 1

• Scales: Yes, texture will be remade automatically

• Works with Color and Gradient layer styles: Yes
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• Works with any texture: No

3. Smart Object with Filter

Create a Solid Color layer, convert it to a Smart Object, select Filter → 
Noise → Add Noise, apply a Vector Mask to match your element, set the 
layer blending mode to Luminosity and reduce the layer’s opacity.

It’s a fairly involved process, but it can accommodate a combination of 
effects that can be remade if the document gets scaled.

• Layers: 2

• Scales: Yes, texture will be remade automatically

• Works with Color and Gradient layer styles: Yes

• Works with any texture: No
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4. Pattern Overlay Layer Style

Start by creating a noise or repeating pattern in a new document, then 
choose Edit → Define Pattern. Once you’ve defined the pattern, it will 
be available in the Pattern Overlay layer style options. As with previous 
methods, using Luminosity as a blending mode and reducing the opacity to 
suit it yield great results.

The Pattern layer style is composited below the Color and Gradient styles, 
ruining an otherwise perfect noise and texture method. However, you can 
create a second layer that just holds the texture if you need to, or start with 
a Gradient Fill layer, sidestepping the limitation.

• Layers: 1

• Scales: Yes, but you’ll need to change the Layer style scale to 100% 
after scaling

• Works with Color and Gradient layer styles: No, the pattern appears 
underneath

• Works with any texture: Yes
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Which Method Is Best?

Although a little cumbersome, creating a Gradient Fill layer, adding a 
Pattern layer style, then creating a Vector Mask seems to be the best 
method possible. This can be used to create flexible, scalable and editable 
single-layer UI elements with texture. As a bonus, Gradient Fill layers can be 
dithered and so also produce the highest quality results (Gradient layer 
styles cannot be dithered).

We’ve created some examples below and included the source document so 
that you can see how they were built.

Download the PSD (.zip)

Rounded Rectangles

Rounded rectangles, or “roundrects” as QuickDraw so fondly calls them, are 
standard fare on a Web and interface designer’s utility belt. They’re so 
common that it’s rare for Web pages or apps to not contain a roundrect or 
two. Unfortunately, pixel-locked rounded rectangles can actually be fairly 
difficult to draw in Photoshop. (By pixel-locked, I mean that every edge falls 
on an exact pixel boundary, creating the sharpest object possible.)

Experienced Photoshop users will probably already know one or two ways 
to draw a roundrect. Hopefully, after reading this article, they’ll also know a 
couple more, as well as which methods produce pixel-perfect results.
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1. Rounded Rectangle Vector Tool

Photoshop’s Rounded Rectangle vector tool appears like the ideal 
candidate for the task, until you realize that the edges it creates are blurry 
and inconsistent.

Fortunately, there is a fairly well-hidden option that locks the Rounded 
Rectangle vector tool’s output to the pixel grid. Excellent.

To enable pixel-locked drawing for the Rounded Rectangle vector tool, 
check the “Snap to Pixels” option in the Options bar. If you have “Snap to 
Pixels” turned off, drawing at 100% zoom achieves the same result.
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The result is perfect roundrects, every time. The only downside is that the 
corner radius can’t be altered during or after drawing the shape. If you 
need a different radius, you’re forced to draw it again. It’s a shame the 
roundrect tool isn’t like Illustrator in this regard, where the up and down 
arrow keys increase and decrease the corner radius while drawing.

On the positive side, keeping your objects as vectors means that you’ll be 
able to resize the document and the corners will take full advantage of any 
extra resolution. There is one small caveat though: if you resize, you’ll have 
to do it as an exact multiple, or risk fuzzy non-pixel–locked edges.

If you’re being pedantic about the results, you may notice that the 
antialiasing on the first half of each corner doesn’t match the second half — 
you’ll have to look carefully to notice, though. For example, looking at the 
zoomed corner below, the start of the corner to the apex isn’t identical to 
the apex to the end of the corner (starting from either side). In practice, 
that probably won’t create any issues.

2. Blur

The blur method is a bit of a hack that involves creating a selection, 
blurring it, then increasing the contrast so that you’re left with a sharp mask 
that’s antialiased nicely.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 12



It’s seven steps in total and is prone to being inaccurate; plus, the radius of 
the corners can’t be changed on the fly. Applying levels can also be a bit 
fiddly. One advantage is that different levels settings can be used to obtain 
different degrees of antialiasing, from incredibly soft to completely aliased.

1. Create a new layer

2. Draw a rectangular selection

3. Enter quick mask (Q)

4. Gaussian blur by half the radius that you’d like for the rounded 
corners. (For example, a 10-pixel radius would need a 5-pixel blur.)

5. Apply Levels (Command + L), and use about 118 for the black point 
and 137 for the white point on the input levels

6. Exit quick mask (Q)

7. Fill selection

On the positive side, this blur method can be used to quickly create some 
interesting and organic shapes that would be difficult to draw by hand.
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3. Circles

The circles method is very accurate and easily reproducible, but has a 
whopping 13 steps. That’s a lot of clicking for just a single roundrect.

1. Create a new layer

2. Make a circular selection that is twice as large as the radius you would 
like (for example, a 10-pixel radius would require a 20×20-pixel circle)

3. Fill the selection

4. Move the selection right. This can be done quickly by holding down 
Shift and pressing the right-arrow key a few times

5. Fill the selection

6. Move the selection down

7. Fill the selection

8. Move the selection left

9. Fill the selection
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10. Make a rectangular selection that covers the entire vertical span of 
the roundrect but that starts and ends halfway through the circles at 
the ends

11. Fill the selection

12. Make a rectangular selection that covers the entire horizontal span of 
the roundrect but that starts and ends halfway through the circles at 
the ends

13. Fill the selection

4. Stroke

The stroke method is very accurate, easily reproducible and has only about 
four steps, depending on the result you’re after. The corners are a bit 
sharper than those of the circle method, though. That may be a good thing 
or a bad thing, depending on your preference.

1. Create a new layer

2. Draw a rectangular selection that is smaller than the area you require 
(smaller by double the radius, if you want to be exact)

3. Fill the selection
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4. Add a stroke as a layer style that is as thick as the corner radius you 
would like

If you’d like to flatten the object to remove the stroke, keep following the 
steps below.

1. Create a new layer

2. In the Layers palette, select the new layer and the previous layer

3. Merge layers (Command + E)

It’s possible to automate the flattening with a Photoshop Action. This can 
also be set up as a function key to speed things up further.

A huge advantage of the stroke method is that it’s dynamic, so the radius 
can be edited in real time. It can also be used to easily create other 
rounded shapes, as seen below.
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Which Method Is Best?

In most cases, using the Rounded Rectangle tool with “Snap to Pixel” 
turned on will give great results and be the quickest method. If you’d like 
the ability to change the corner radius without redrawing, then the stroke 
method is the one to use.

However, as seen below, each method yields different results. So, 
depending on what you’re after, you may need to use a combination of 
methods.
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All tests were completed using Photoshop CS4 and CS5 on a Mac. Behavior 
for both versions was consistent.
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Gradients

Gradients are a great way to add life-like lighting and shading to surfaces. 
When built with gradient layers and layer styles, they also ensure that UI 
elements can be scaled and reused easily.

Linear Gradients

Linear gradients are gradients in their most basic form — a gradual blend 
of colors and following a straight line. I’m sure you knew that, so onto the 
more interesting stuff.

Reflected Gradients

Reflected gradients are like their linear friends, but they repeat the gradient 
twice, with the second repeat mirrored. This makes editing a little less 
tedious, provided it fits the result you’re after.
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Radial Gradients

Radial gradients start from the center (or any chosen point) and grow 
outward in a circular pattern. They’re handy for creating spheres and 
applying effects to the edge of circular elements. The center point of the 
gradient can be moved by clicking and dragging on the canvas while the 
gradient window or layer styles window is open.
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Angle Gradients

Angle gradients can be a great way to mimic environmental reflections 
found on highly polished metallic objects. The center point of the gradient 
can be moved by clicking and dragging on the canvas while the gradient 
window or layer styles window is open.

Gradients on Gradients

Anything worth doing is worth overdoing, right? Combining a gradient 
layer with a gradient layer style lets you overlay two different gradients, 
giving more complex and — here’s the good part — completely dynamic 
results. To combine the gradients, you’ll need to set a blending mode for 
the gradient layer style. For the examples below, I’ve used either Screen 
(good for lightening) or Multiply (good for darkening).
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Dithering Is Everything

Adding dithering to a gradient produces smoother results. Non-dithered 
gradients often contain visible banding. Dithering is even more important if 
your artwork is being viewed on cheaper 6-bit per channel TN LCDs and 
certain display types that tend to amplify posterization problems.
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If you’re not seeing the difference, here’s an extreme and completely 
unrealistic example of gradient dithering in action:

Ensuring that your gradients are dithered is easy: just check the appropriate 
box in Photoshop.
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Note that gradient layer styles can’t be dithered, and gradients in placed 
objects (such as stuff you’ve pasted from Illustrator) aren’t dithered.

If you use transparency in a gradient, that won’t be dithered either, which 
can be a huge issue at times. There is a solution for some specific cases: if 
you’re using a gradient with transparency to lighten an area with white, 
then using a non-transparent gradient with a Screen Layer blending mode 
will let you dither it. The same technique can be used for darkening with 
the Multiply blending mode.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 24



A combination of the gradient techniques described above were used to 
create the Mac app icon below.

Gradient Maps

Quite different to other types of gradients, gradient maps can be a great 
way to add color treatment, allowing for very precise control. Gradient 
maps use the brightness of each pixel to map to a corresponding color in a 
gradient.

If the gradient starts at red and ends at blue, then everything white in the 
image will turn red, and everything black will turn blue. Everything in the 
middle tonally will map to the gradient, depending on how bright it is.

The image below was used in a poster for Kingswim, a swimming school:
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With a gradient map.

Without the gradient map, things look quite different. It’s a composite of 
about seven photos; the boy and background were shot on black and white 
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film with intentionally low contrast so that the grain would be more 
prominent when the contrast was pushed by the gradient map. The 
gradient map also hides the color mismatches in the compositing.

Gradient map off.
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A Little Obsessed?

Absolutely. I conducted all of the tests above to learn more about some 
common techniques that I already use: that is, to reassess and fine tune, 
with the aim of improving my designs. Creating great artwork without 
intimately knowing your tools is certainly possible, but the more you know, 
the more likely you are to work faster and with greater confidence.
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Useful Photoshop Tips And Tricks for 
Photo Retouching
Dirk Metzmacher

When it comes to designing in Photoshop, there is a myriad of ways one 
could use to achieve a certain result, especially when it comes to photo 
retouching. Designers use technique they are most confident as well as 
comfortable with, which is great because it’s always useful to peek into the 
workflow of our colleagues and learn new design approaches.

I’ll be covering some of the useful techniques and tricks which I’ve learned 
from my experience. You may know some of them, but hopefully not all of 
them. All images used in this article were purchased and are used according 
to their licenses.

Here is a short overview of the techniques we’ll be covering:

• Naturally Increased Light

• Simulating Infrared Images

• Levels

• Color Look With An Adjustment Layer

• Controlling Mid-Tone Contrasts

• Sunset

• Creating Smiles

• Colorful Water Drops
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• Skin Color

• Matching Skin Tones

• Reducing Noise

• Retro Look With Curves

• Identifying Layers

• Conserving Resources

• Classy Sepia Look

• Precise Positioning

• Applying Layer Styles Multiple Times

Naturally Increased Light

The light of the sun creates texture. There are shadowy areas and spots 
where the sunlight can shine without interference. To control the intensity, 
you can draw more light onto a separate layer or increase already existing 
light. Create a new layer by going to Layer → New → Layer, or by pressing 
Shift + Control + N on Windows or Shift + Command + N on a 
Mac. Set the blending mode to “Color Dodge” and the opacity to about 
15%.
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Increase light on a separate layer.

Then use the brush tool with a soft brush, and hold the Alt/Option key 
to pick up colors from the area that you want to brighten. Continue to 
brush in some light, picking up appropriate colors if the background 
changes. This way, you increase not only the light, but the saturation, which 
makes for more realistic results.
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The blending mode “Color Dodge” creates realistic results.

Simulate Infrared Images

Open a photo in Camera Raw; you can do this either in Bridge, using the 
right mouse key and clicking “Open in Camera Raw,” or directly in 
Photoshop, by selecting File → Open as Smart Object. Apply basic 
adjustments to optimize your image (for example, with the “Recovery” and 
“Fill Light” slides), then switch to the “HSL/Grayscale” tab. Check “Convert to 
Grayscale,” and set the Blues down to around -85. Set the Greens to +90 
and the Yellows to +20.

Trees and bushes should now shine in the typical white, and the sky should 
appear almost black. If you want to go on and simulate some grain, switch 
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to the “Effects” tab, and enter 15 for the amount, 20 for size and 80 for 
roughness. You could also apply a “Vignette.” Here I used -30 for the 
amount, 40 for the midpoint and -35 for roundness.

It’s almost like an infrared image.

Levels

When applying a “Levels adjustment,” you can set black and white points in 
order to decrease color tints, but where are the darkest and brightest spots 
in the image? Go to New Adjustment Layer → Threshold to find those areas. 
This function is available under the “Layer” menu.
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Move the slider so far to the right that only a few white spots remain in the 
document. Use the “Color Sampler tool” and set down a point there. Move 
the slider to the left until only a few black spots remain, and set a second 
point down there.

One could also find a neutral gray in the image by using a “Threshold 
adjustment layer.” Add a new blank layer between the original image and 
the threshold adjustment layer, and fill this layer with 50% gray. Go to Edit 
→ Fill or press Shift + F5, then select “50% Gray” under “Contents” and 
click “OK.”

Here is the threshold adjustment layer at work.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 34



Change the blending mode of this layer to “Difference.” Select the 
“Threshold adjustment layer” again and move the slider all the way to the 
left. Slowly move the slider back to the right until black dots start to appear. 
These are the neutral gray areas in the image (if neutral grays are present). 
Add a “Color Sampler spot.”

Now delete both the threshold adjustment layer and the 50% gray layer. 
Create a new adjustment layer, “Levels.” Use the first Eyedropper tool to 
click on the darkest area, then use the third Eyedropper on the brightest 
area.
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Here’s a before-and-after comparison.
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Now you can use the gray Eyedropper tool on the third Color Sampler spot. 
The color tint will be decreased. Color Sampler spots can be deleted by 
dragging them off the canvas with the Color Sampler tool.

Color Look With An Adjustment Layer

Go to the Layer menu, and then New Adjustment Layer → Hue/Saturation, 
and set the blending mode to “Soft Light” and check “Colorize.” Use the 
Hue, Saturation and Lightness sliders to control the color: for a cool look, 
for example, set the hue at 210, the saturation at 50 and the lightness at 10; 
for a warm look, set the hue at 30, the saturation at 30 and the lightness at 
5.

Here is Hue/Saturation and Color Fill.
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Alternatively, you could use several color layers. Create them from the layer 
palette with the “New Fill/Adjustment Layer” button. Choose a color, then 
set the blending mode to “Vivid Light.” Reduce the opacity to about 12%, 
and invert the layer mask with Control/Command + I. Paint in the 
colored light with a big brush and white color. This works especially well for 
the lighting in portraits that have a textured background.

Here’s the Color Look with an Adjustment Layer.

Controlling Mid-Tone Contrasts

To increase detail in landscape shots, boost the mid-tone contrast. Copy the 
background layer with Control/Command + J, and then click on Filter → 
Convert for Smart Filters in the menu. Then go to Filter → Other → High 
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Pass and enter a radius of 3 pixels. Change the blending mode to “Overlay” 
and double-click the layer next to its name to open the “Layer Style” 
window.

Layer Style window: This Layer

For the first gradient, “This Layer,” split the sliders by holding the Alt/
Option key and trim the layer effect to the “50/100” and “150/200” 
ranges. As soon as you move the sliders, you’ll see where those numbers 
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are. This increases contrast only for the mid-tones. Double-click the “High 
Pass” filter in the layer palette to bring the dialog box up again in order to 
adjust the radius to your liking.

Check out these mid-tone contrasts.

Sunset

A sunset, especially at sea, can be an amazing color spectacle. The hues will 
depend heavily on the weather, though — but you can push them a bit with 
a gradient map. Click on the “New Fill/Adjustment Layer” button in the 
Layer palette and select “Gradient Map” from the list. Click on the gradient 
to open the “Gradient Editor.”
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Gradient Map

Click on the first color patch below the gradient, and change the color to 
red. Set the color patch on the opposite side to yellow, and click “OK.” Set 
the blending mode to “Soft Light” and reduce the opacity to about 50%. 
This will create a warm, almost golden sunset.
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Observe the movement from a blue to a golden sunset.
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Creating Smiles

Roughly select the area around the mouth with the Polygon Lasso tool. Go 
to Select → Modify → Feather, and enter a radius of 10 pixels. Confirm, then 
click on Layer → New → Layer via Copy (or press Control/Command + 
J), then Edit → Puppet Warp. Photoshop will put a mesh over the entire 
layer in the shape of your previous selection.

Here’s the mesh over the layer.

You can control the size of the mesh with the “Expansion” value in the 
Options bar. Increase the density to “More Points” for increased precision. 
Press Control/Command + H to hide the mesh, then set the first pins to 
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the corners of the mouth. Add more pins to distinctive spots of the mouth. 
By clicking and dragging the mesh, you can shape a nice smile.

Colorful Water Drops

Macro shots of water drops are appealing, and shapes can be further 
accentuated with discreet coloring. You could treat the bland surface with a 
linear gradient from #772222 (RGB 119, 34, 34) to #3333bb (RGB 51, 51, 
187). If the photo is on a layer of its own, click on Layer → Layer Style → 
Gradient Overlay or double-click the layer next to its name.

Layer Style: Gradient Overlay
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Set the blend mode to Color, the opacity to 50%, the gradient to 
“Foreground to background color” and the angle to 90%. The gradient will 
be saved as a layer style, so you can come back at any time to adjust the 
values. Double-clicking the style name opens up the dialog window once 
more.

See the colorful drops with optimized colors.
Useful Photoshop Tips And Tricks For Photo Retouching (2)

Skin Color

If the skin is not quite perfect after retouching, it might be because of the 
general hue. You can control it by going to New Adjustment Layer → Hue/
Saturation. Click on the miniature mask, and press Control/Command + 
I to invert the mask.
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Adjustment Layer: Hue/Saturation

Using white color and a soft brush, paint over the skin areas so that only 
they get treated. For the adjustment, switch from Standard to “Reds” (found 
in the Hue drop-down menu of the Adjustment layer), and use the Hue, 
Saturation and Lightness sliders to adjust the skin color. Switch to “Yellows” 
and optimize the skin tone. Getting the colors exactly right depends very 
much on the image material. Rely on your common sense.
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Optimized skin tones

Matching Skin Tones

A sunburn or a blush can disrupt a portrait, especially if there is a 
contrasting pale person nearby. Photoshop has a tool to correct that: 
“Match Color” offers control over skin tones. Open your image and use the 
Quick Selection tool to roughly select the red skin areas.

You can hold down the Alt/Option key and subtract areas from the 
selection. Click on Select → Modify → Feather and enter a value of about 15 
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pixels. Use the Control/Command + J shortcut to copy the selection to a 
new layer.

Adjustments: Match Color
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Using the same technique, copy the non-reddened skin to a new layer. In 
the next step, you’ll have to differentiate between the source layer and the 
layer to edit, so rename these two layers meaningfully; all it takes is a 
double-click on the layer name. You could use the naming scheme shown 
here and call them “Beautiful skin” and “Reddened skin.”

Activate the layer with the red skin, and select Image → Adjustments → 
Match Color from the menu. For “Source,” select the current document, and 
for “Layer,” select the one with the beautiful skin. Control the effect using 
the “Luminance” and “Color Intensity” sliders in the Image Options area. 
Once you confirm, you can control the effect’s strength with the Opacity 
slider.
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Paler skin after Match Color
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Reducing Noise

Noisy images are annoying. One way to reduce noise is through the 
channels. Copy the background layer by pressing Control/Command + 
J, switch to the Channels palette, and select the channel that shows the 
least noise. Drag that channel down to the “New Channel” icon (next to the 
trash can) and go to Stylize → Find Edges. Then apply a Gaussian Blur with 
a radius of about 3 pixels.

Look at this copy of the red channel.

Click on the new channel’s miniature icon while holding the Control/
Command key to select the content. Activate the “RGB channel” (top-most), 
and switch back to the Layers palette. When the duplicated background is 
selected, click on the “Add Layer Mask” icon.
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Click on the Layer Miniature icon, and select Filter → Blur → Surface Blur 
from the menu. Play around with the Radius and Threshold sliders until the 
noise has been reduced as much as possible. Thanks to the mask you 
created, the contours are safe.

With and without noise
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Retro Look With Curves

Go to Layer → New Adjustment Layer → Curves and switch from RGB to 
Reds. Then drag the line downwards a little for the shadows and upwards 
for the highlights, creating a slight “S” curve. Do the same for the Greens. 
For the Blues, drag the highlights down a little and the shadows up (for an 
inverted S shape). The shadows should now be slightly blue-ish, the 
highlights slightly yellow-ish.

Adjustment Layer: Curves
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Create a new layer with Shift + Control/Command + N, and fill it with 
#000066 (RGB 0, 0, 102). Set the blending mode to “Exclusion.” Now copy 
the background layer by clicking it and pressing Control/Command + J. 
Set the blending mode for this copy to “Soft Light.”

To decrease the effect overall, activate the top-most layer and then click on 
the background copy while holding the Shift key, thereby selecting both 
layers. Alternatively, you can add them to a group with Control/Command 
+ G. Reduce the layer’s (or group’s) opacity. Note that in Photoshop 
versions prior to CS5, you’ll have to reduce the opacity for each layer 
individually.
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Achieve a simple retro look in a few steps.
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Identifying Layers

If you’re ambitious with your collages, then you’ll be familiar with this 
problem: meaningful layer names are often neglected during the creative 
process. This can result in layer names like “Layer 4” and “Layer 5 Copy 2,” 
which are not very helpful when you need to quickly identify the contents 
of a layer.

Photoshop offers a number of solutions for our laziness. For example, you 
can click on the element you want to select by using the “Move tool” and 
holding the right mouse key; you’ll see which layer contents are below the 
tool. Photoshop will display a list in a drop-down menu, from which you 
can easily select the desired element.

Right click with the Move tool
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Control/Command + left-click with the Move tool selected and, in 
most cases, you’ll select the corresponding layer of the element that your 
mouse is over (unless Photoshop can’t distinguish between the multiple 
layers).

You could also Control/Command + left-click on a layer’s miniature 
icon to get a selection of the content of that layer. The marching ants will 
show you what is on that layer and where it is.

Another option is to click on the Layer palette’s Options icon, in the top-
right corner, and select “Layers Palette Options.” From here you can adjust 
the size of the layer’s miniature preview and concentrate the miniature’s 
content to the layer’s bounds, which should cut down on future guesswork 
when it comes to layer contents.
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Layers Palette options
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Conserving Resources

Plug-ins save time, but they’re a bit resource-hungry; at least, they lengthen 
Photoshop’s start-up time. Your plug-ins might have functionality that you 
rarely use, so deactivate them until you need them. To do so, create a new 
folder by going to Adobe → Adobe Photoshop CS5 (or whatever your 
version) and name it something like Plugins_deactivated.

After disabling some plug-ins.

Now move all of the extensions that you don’t need for the moment. When 
you restart Photoshop now, those plug-ins won’t load, so the program will 
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start up quickly. Your RAM will be relieved. Because you neither deleted nor 
uninstalled the plug-ins, they’re available to use anytime. If you need them, 
just move them back to the plug-in folder.
Useful Photoshop Tips And Tricks For Photo Retouching (3)

Classy Sepia Look

The sepia look is an absolute classic. To enhance a black and white image 
with a classy sepia tone, follow these steps. Click on Layer → New 
Adjustment Layer → Photo Filter, and select the Sepia filter, with a density of 
100%. Double-click the layer (not the layer name) to open up the Layer 
Style window. This will show the Blending options.
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A view of the Layer Style window.

At the bottom of the dialog box for the first gradient, move the white slider 
to the left while holding the Alt/Option key. This creates a smooth 
transition between adjusted and unadjusted areas. The sepia will now look 
elegant.
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Subtle sepia

Precise Positioning

I’m sure you’ve often been irritated by Photoshop’s tendency to position 
elements on its own, but the program is just trying to help you align an 
element that is on its own layer with the outer edge of the document or 
with the edge of another object. To your frustration, the layer’s content will 
jump to the edge, even though you wanted to leave a few pixels of space in 
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between. You can temporarily deactivate the automatic snapping by 
holding the Control/Command key as you position.

A banner, close to the edge.

Applying Layer Styles Multiple Times

Usually, layer styles can be applied only once. For example, if you click on 
Layer → Layer Style → Drop Shadow, you cannot create a double drop 
shadow, one of which has an angle of 120°, a distance of 2 pixels and a size 
of 2 pixels, and the other of which has an angle of 180°, a distance of 12 
pixels and a size of 12 pixels.
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Actually, it is possible! It just requires a little detour. Create the first drop 
shadow as you normally would. Then right-click on the layer and select 
“Convert to Smart Object” from the menu. This smart object can be 
assigned another drop shadow, and you can convert the smart object into 
yet another smart object. This way, you can easily add a third and fourth 
drop shadow. Alternatively, you could apply multiple strokes.

Three shadows in combination.

By the way, to put one or even several styles onto their own layers at once, 
right-click on the FX symbol and select “Create Layer” from the list. Now 
you can apply filters to these styles, but they won’t be editable anymore.
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Photo Retouching Tips and Tricks in 
Photoshop
Dirk Metzmacher

We have had articles on various tools in Adobe Photoshop but this one is 
focused more on the techniques rather than the tools provided. Please note 
that all images used in this article were purchased and are used according 
to their licenses. Here is a short overview of the techniques we’ll be 
covering in this follow-up:

• Defining Colors

• Controlling Folders

• Split-Toning Effect

• Flexible Vignette

• Skin Retouching In Camera Raw

• Setting Lights

• Distinguished Paleness

• Dodge And Burn Look

• Bright Eyes

• The Orton Effect

• Optimizing Lasso Selections

• Aligning Layer Contents

• Restoring Selections

• More Photoshop Tips and Tricks
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Defining Colors

If you want to redefine the foreground and background colors, use the 
Eyedropper tool to select the foreground color, and then switch the 
position with the background color, maybe by using the shortcut X, and 
pick up the next color. But there is an easier way. First, define the 
foreground color just as you’re accustomed to, but then define the 
background color by holding the Alt/Option key. Instead of changing the 
foreground color, you’ll redefine the background color with just one click.

Define foreground and background colors.
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Controlling Folders

Folders give structure to layers, which is especially important if you’re 
working on demanding compositions. Folders are often collapsed, so you 
can’t see the contents at first sight. This conserves space but it’s not always 
desirable. If you want nested layers to reveal their contents and offer a 
quick overview, hold the Control/Command key and click on one of the 
triangles to expand. All folders at the first level will expand. You can 
collapse them again using the same trick. To expand all nested folders 
inside the folders as well, hold the Alt/Option key as well as the 
Control/Command key.

Hold the Control/Command key to expand the folder.
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Split-Toning Effect

Create two new gradient maps via Layer → New Adjustment Layer → 
Gradient Map. You could, for example, create a gradient from dark-blue to 
beige and another from dark-brown to white. To change a gradient, click on 
it to open up the “Gradient Editor” dialog box. There, click on your chosen 
color patches and open up the color picker via the “Color field.”

Blending Options: This Layer
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Confirm with “OK,” double-click the layer with the second gradient map 
and, under “This Layer,” move the right slider to the left. To make the 
transition a little smoother, click on the slider while holding down the Alt/
Option key and move it to the right. Confirm with “OK.”

Split-Toning Effect
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Flexible Vignette

To create a non-destructive vignette, go to New Adjustment Layer → Levels. 
Darken the image completely by, for example, setting the Highlights down 
to 80. Now use the Brush tool with black color to paint the light center into 
the layer mask. Instead of using a brush to paint the area, you could use the 
Elliptical Marquee tool and fill the selection with black.

Adjustment Layer: Levels
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You can use the Move tool to adjust the vignette’s position any time, or blur 
it using the “Gaussian Blur.” You can also increase or decrease the 
darkening. To do so, open the Levels Adjustment dialog box again.

Skin Retouching In Camera Raw

Again, open a photo in Camera Raw (for example, by using the right mouse 
key from Bridge and clicking “Open in Camera Raw”). In general, you can 
use the Spot Healing Brush tool and all other tools and sliders to improve 
the image. When you’re happy with it, hold the Shift key and click on 
“Open Object.” The image will be put on a new layer as a Smart Object.

You could also click the blue link at the bottom of the screen, which opens 
the “Workflow Options” dialog window. From there, you can control some 
other settings as well. Make sure to check the “Open in Photoshop as Smart 
Object” checkbox, and then confirm with “OK” to open the images (without 
having to holding Shift).
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Here, layers are smart objects.

Right-click on the layer and choose “New Smart Object via Copy,” and then 
open the Camera Raw dialog box again by double-clicking the layer icon. 
Set the “Clarity” value to -100 and confirm with “OK.” Hold the Alt/
Option key and click on the “Create Layer Mask” button, then use a soft 
brush to paint over the optimized skin. Use the opacity slider to control the 
amount of retouching.
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Here is optimized skin with the help of Camera Raw.

Setting Lights

If you want to do some virtual re-positioning of your strobes, then 
neutralize the shot first. Go to Select → Color Range, and set Select option 
to “Highlights.” Copy the selection content to a new layer by hitting 
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Control/Command + J. Activate the background layer again, and select 
the “Shadows” this time. Bring those to their own layer, too, with Control/
Command + J, and then set the blending mode to “Screen” and the 
highlights to “Multiply.”

Highlights and shadows

Reduce the opacity to about 30%, depending on the image content. 
“Shadows/Highlights” might also help. On a new layer, filled with a neutral 
gray and its blending mode set to “Overlay,” paint in the desired light 
quality with the Dodge and Burn tools. Alternatively, add a new layer and 

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 74



set its blending mode to “Soft Light” or “Overlay” and, with a low opacity 
brush, paint black and white on this layer.

The lights were neutralized a bit.

Distinguished Paleness

For a distinguished paleness, copy the background layer and set its 
blending mode to “Screen.” Use Image → Adjustments → Desaturate or 
“Black & White,” then “Shadows/Highlights” to increase the effect. The exact 
adjustment options can vary according to your image content.
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Here’s the layer after creating the mask.

The effect will cover the entire image unless you click on the “Create Layer 
Mask” button while holding the Alt/Option key, and then paint the pale 
areas with the brush tool and white color. You can control the effect’s 
strength with the opacity slider.
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Distinguished paleness.

Dodge And Burn Look

Copy the reduced layers to a new layer with Shift + Control/Command 
+ Alt/Option + E, and then set the blending mode to “Vivid Light.” Use 
Control/Command + I to invert the layer content, and apply Filter → Blur 
→ Surface Blur with a radius of about 70 pixels and a threshold of 40 levels. 
Press Shift + Control/Command + Alt/Option + E again, delete the 
layer below, and set the blending mode to “Overlay.” Apply a “Gaussian 
Blur” to make the contours a little softer, and then click Image → 
Adjustments → Desaturate.
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Dodge and Burn Look

Photo Retouching Tips And Tricks In Photoshop (2)

Bright Eyes

To make eyes appear brilliant, click on New Adjustment Layer → Exposure. 
Fill the layer mask with black (or invert the mask), and paint with white over 
the irises and with black over the pupils. Set the blending mode of the 
adjustment layer to “Luminosity.” Increase the exposure in concert with the 
gamma value to give the iris structure more contrast. Also, try changing the 
“Offset slider.”

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 78



Create beautiful eyes with exposure.
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The Orton Effect

With the Orton effect, sharp and blurred versions of a photo are mixed 
together. Copy the background layer with Control/Command + J, and 
click on Image → Apply Image. Change the blending mode to “Screen” and 
click “OK.” Copy the current layer again with Control/Command + J. 
Apply a Gaussian Blur to this copy by clicking Filter → Blur → Gaussian Blur. 
The value will depend on the size of the image. The shapes should always 
blur slightly. Set the blending mode for the layer to “Multiply.”

The Orton effect creates contrast and depth.
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Optimizing Lasso Selections

Many users (even professionals) prefer the Lasso Selection tool to the Path 
tool for uncomplicated selections. To switch to the Polygon Lasso tool for a 
short stretch, hold the Alt/Option key while working. To switch back to 
the regular Lasso tool, just release the Alt/Option key while depressing 
the mouse button.

Switching between the Lasso and Polygon Lasso tools is easy.
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It often happens that, during a zoom, you hit the edge of the work area 
while making a selection. Just keep the space bar pressed to switch to the 
Hand tool, and you can quickly change the displayed image section.

Aligning Layer Contents

Some areas in Photoshop are hardly ever noticed. This is one of them. If 
you activate the Move tool, you’ll see some mysterious symbols to the right 
called Align tools, in the option bar next to Auto-Select and the Transform 
controls (which are basically equivalent to Free Transform).

Align tools

If you activate just one layer, the Align tools won’t do anything, but if you 
select two or more layers by holding the Control/Command key, then you 
can align the layer’s contents with these buttons. Choose from options such 
as “Align Top Edge” and “Align Vertical Center.”
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Restoring Selections

Often, while in the middle of working on a tricky selection, you’ll 
accidentally deselect it by clicking once too often. You can restore the lost 
selection by pressing Shift + Control/Command + D. This will get the 
ants marching again. You can also undo (Control/Command + Z) the 
action, and even perform multiple undos with Control/Command + Alt/
Option + Z.

By the way, you can hold the Alt/Option key to subtract elements from 
the selection at any time, or hold the Shift key to add to the selection. 
Pressing a combination of both keys creates a selection intersection. 
Important selections that you might need later can be saved by going to 
Select → Save Selection.

Restore lost selections.
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The Ultimate Guide to Cloning in 
Photoshop
Joshua Johnson

Photoshop’s wide array of cloning tools is the cause of many of the 
absolute best and worst works created with the application. In a skilled and 
experienced hand, these tools lead to phenomenal results. In the hands of a 
careless artist, Photoshop cloning can be disastrous to the credibility of the 
result. This article introduces the several cloning tools available in 
Photoshop and goes over the proper usage and best practices of each.

The Clone Stamp Tool

The Clone Stamp tool is the oldest and most widely known of the cloning 
tools. The basic concept is that you duplicate certain portions of an image 
using a source, destination and brush.
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Use the “Option” key (“Alt”) to set the source.

To clone out the name on the tombstone above, you would select a source 
that shares the texture of the area you want to replace. In this case, the area 
around the words provides an ample source of stone texture from which to 
clone.

To begin, simply click on the preferred source area while holding down the 
“Option” key (“Alt” on a PC). Then, with no keys held down, begin painting 
over the area you want to replace. The image area from the source will be 
transferred to the destination.

To be able to use this tool effectively, let’s look at the relevant settings.
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Basic Settings: Brush

Below, you’ll find the default settings when the clone stamp is selected.

The clone stamp’s basic settings.

The first setting you’ll want to familiarize yourself with is for the brush. 
Photoshop does not restrict cloning to a basic default brush. Instead, it 
allows you to use any brush you want, allowing you to create an unlimited 
number of effects. In the example above, and in most cases in fact, a small 
to medium-sized round soft brush gives the best result.

A hard brush creates noticeable seams.

As you can see, a hard brush often creates visible edges along the path of 
the clone. The transition is much smoother on the left side, where a soft 
brush was used. Both sides suffer from noticeable replication, but this was 
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intentional to exaggerate the cloned area. We’ll discuss how to avoid this 
later.

As stated, while a soft round brush is recommended for basic cloning, a 
number of interesting effects can be created using alternate brushes. For 
instance, below I’ve used a scatter brush shaped like a leaf to add some 
visual interest to the photo.

Use a scatter brush to create interesting particle effects.

Experiment with the opacity, blending mode and brush flow for an even 
wider variety of results.
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Basic Settings: Sample

Under the “Sample” menu are three options: Current Layer, Current & Below 
and All Layers. These options affect the area you are sourcing. Here’s a 
visual illustration of how each mode works:

The area cloned depends on the selected layer and sample mode.
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As you can see, with Current Layer selected, the clone stamp ignores pixel 
data contained in any other layer. Conversely, All Layers ignores all layer 
distinction and clones any visible pixels in the document (invisible layers 
will be ignored). Finally, Current & Below samples pixels from the selected 
layer and any visible layers behind it.

Basic Settings: Adjustment Layers

The final basic setting (the circle with a diagonal line through it) lets you 
decide whether the clone stamp tool should sample adjustment layers 
when cloning. Adjustment layers, such as Hue/Saturation and Levels, are 
meant to be a non-destructive way to change the appearance of layers. So, 
you can make drastic changes to a layer or group of layers without 
destroying the original pixels.

Because of this, turning on Ignore Adjustment Layers When Cloning is 
almost always a good idea. This allows you to clone the original image, 
which can then be affected by an ever-changeable adjustment layer. If you 
do not choose to ignore the adjustment layer, the adjustment becomes 
permanent in the cloned areas.

In the layer set-up below, turning on Sample All Layers would by default 
clone pixels from both the background layer and the adjustment layer in 
the foreground. Turning on Ignore Adjustment Layers prevents this.
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You can choose to ignore adjustment layers when cloning.

The Spot Healing Brush

As you can see below, the Spot Healing Brush tool is located under the 
Eyedropper tool and above the Brush tool, and it can be accessed quickly 
by hitting J on the keyboard.
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Type J to bring up the Spot Healing Brush.

The Spot Healing Brush is by far the simplest cloning tool in Photoshop. 
With little to no experience, you can repair small areas of an image. The 
secret to using the tool is in the name: Spot Healing. The tool is intended 
not for large areas of replacement, but rather to remove little unwanted 
spots, such as a scratch on an old photograph or a mole on a person’s face.

To use the tool, simply hover over the area you want to replace and click 
once. Photoshop does all the work by examining the pixel data around the 
spot and seamlessly integrating the data into the destination.
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The Spot Healing Brush is perfect for repairing old photographs.

As you can see above, the tool does a remarkable job of not leaving behind 
any noticeable artifacts or repeating patterns. The trick is to go slowly and 
work on very small portions of the image. Select a spot to fix, and use a 
brush that’s only slightly bigger than the selected imperfection. The larger 
the brush, the more likely you are to clone unwanted portions of the 
surrounding area, and the more noticeable the repetition of pixels will be.
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Use a brush slightly bigger than the target spot.

The Healing Brush

The Healing Brush tool, located under the Spot Healing Brush tool, is very 
similar to the Clone Stamp tool. To begin, Option + click (Alt + click on a 
PC) to select your source, and then carefully paint over the destination to 
transfer the pixels. The Healing Brush performs this operation with more 
built-in intelligence than the Clone Stamp.

As with the Spot Healing Brush, the Healing Brush attempts to 
automatically blend in the cloned pixels with the environment around it.
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The Healing Brush tool automatically blends the source with the destination.

As you can see, using the Clone Stamp to clone the puppy’s eye results in a 
straight copy of the pixels, while the Healing Brush does a much better job 
of blending with the background.

This built-in intelligence proves extremely helpful when cloning a subject 
with diverse colors, textures and lighting conditions. Using the Clone Stamp 
in these situations can leave you with a lot of noticeably patchy spots that 
really stand out from the surrounding area.
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The Healing Brush Tool makes it easy to clone visually complicated areas.

The photograph above is a good example of a subject with a fairly 
complicated surface. Using the Clone Stamp tool would have made it quite 
difficult to paint over the cracked areas while retaining the integrity of the 
stained stone. Much of the discoloration would have been sacrificed as you 
sourced smoother areas to erase the cracks. However, the Healing Brush 
was able to effectively replace the cracked areas with smoother areas, while 
sampling from the surrounding area to replicate the stains.
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The Patch Tool

The final healing tool we’ll examine is the Patch tool, which can be found 
under the Healing Brush tool, as seen below.

Tip: hit Shift + J to cycle between the tools in the fly-out menu.

The cloning tools we’ve examined so far are best when used meticulously 
on small portions of an image. By contrast, the Patch tool is the best way to 
clone large, relatively uniform areas. As with the other healing tools, the 
Patch tool not only performs a straight clone but attempts to blend in the 
edge of the selected area with the target environment.

To use the Patch tool, either make a selection with any of the selection 
tools, or simply select an area with the Patch tool’s built-in lasso. There are 
two modes to choose from for the behavior of the patch: “Source” and 
“Destination” (found in the menu bar above the document area).
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Source Mode

With the source mode selected, first select the area of the image you want 
to replace, and then drag that selection to the area you want to source. For 
instance, to eliminate the golf ball in the image below, you would first 
select the area around the golf ball, and then drag that selection around to 
find the best source.

In source mode, first select the area you want to replace.

As you drag the selection around to find a suitable source, watch the 
destination (i.e. your originally selected area) for a preview of what the 
source pixels will look like in that area. Keep in mind that this preview is a 
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straight clone without any blending (the final image will look much better). 
Release the selection to see the actual result.

The Patch tool’s result.

As you can see, it does a pretty impressive job of blending the source and 
destination pixels all on its own. But going over areas that need 
improvement with the Healing Brush is good practice.

Destination Mode

With “Destination” mode selected, the area you select first will be the area 
that is replicated elsewhere. For instance, if we start with the same selection 
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as before, dragging the selection this time gives us a preview of copying 
the ball to a new location.

Patch tool destination mode.

After you release the selection, the golf ball is copied to a new area of the 
image and blended with the surrounding pixels.
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Result of “Destination” mode.

The Ultimate Guide To Cloning In Photoshop (2)

The Clone Source Palette

The Clone Source palette (found under Window → Clone Source) is an 
invaluable resource for professional-quality cloning. This tool gives you 
much more control over the results and functionality of the Clone Stamp 
and Healing Brush.

The Clone Source palette contains three primary sections: cloning source, 
offset adjustment and overlay options.
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The Clone Source palette.
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Cloning Sources

In the first section in the Clone Source palette, you can define multiple 
areas of an image as a source from which to clone and/or heal.

Defining multiple sources.

The image above illustrates an example of when you might want to define 
multiple sources. To save a source, click on one of the five source buttons, 
and then Option + click (Alt + click) with either the Clone Stamp or Healing 
Brush. That location will now be saved to that button. Now, select the next 
button in line, and do the same in another part of the image. Once your 
sources are loaded, you can quickly shift between them simply by clicking 
the related button.
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Notice that the file name appears just under the clone source buttons. This 
is because you can actually select a clone source outside of the image that 
you’re working on. Simply open a different file and set the clone source. 
Then, when you go back to the primary file to paint with the Clone Stamp 
or Healing Brush, the pixels from the other image will function as the 
source of the clone.

Offset Options

The second section of commands in the Clone Source palette really 
increase the variety of cloned results available to you. You can set exact 
coordinates for the source, change the size of the cloned result relative to 
the original source, tweak the rotation of the result and set a precise offset 
(again, relative to the original source).

Tweaking the cloned results.
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You can see these transformation effects in action in the example above. 
The two bails of hay are actually one and the same, but they look 
considerably different because of the offset options. First, I set both the 
width and height to 90%, so that the cloned bail would appear slightly 
smaller than the original. Then I changed the width to -90% to flip the 
clone horizontally (you could change the height to a negative number to 
flip the image vertically). Finally, I set the rotation to 10° to give the illusion 
of a small hill.

Overlay Options

The overlay options are among the most helpful features in the Clone 
Source palette. Years ago, cloning involved a lot of guess work because it 
was difficult to tell exactly what the selected sample would look like without 
actually applying it. The guesswork has been eliminated with the “Show 
Overlay” command. When “Show Overlay” is selected in conjunction with 
the “Clipped” option, your brush is shown with a preview of the clone 
source inside. This is extremely helpful when attempting to clone inorganic 
areas with straight edges, such as a brick wall.
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An overlay of the source is displayed within the brush.

Note that if you choose to turn on the overlay but turn off “Clipped,” then 
your entire clone source layer will be shown surrounding the brush.
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An overlay of the source is displayed within the brush.

Working this way is actually quite difficult because the source significantly 
blocks your view of the destination. But if you prefer it, try reducing the 
opacity of the overlay so that you can see the image below.

Vanishing Point

Vanishing Point takes cloning to an entirely new dimension, literally. The 
tool makes it possible to set up primitive planes across your artwork, which 
a clone then follows to simulate a three-dimensional space. Vanishing Point 
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has a ton of features and potential applications, and it really merits its own 
entire article, so this will be just a brief introduction.

When you open up the Vanishing Point dialog (found under the “Filter” 
menu item), you’ll see a large preview of your image, along with a small set 
of tools on the left side.

The Vanishing Point dialog.

Grab the tool sitting second from the top to set up your initial plane. With 
this tool, click once on each of the four corners, outlining the desired plane. 
Once you’ve created an initial plane, you can Command + click (Control + 
click on a PC) to extend the plane perpendicularly. Some images, though, 
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like this old barn, won’t have perfect angles. In this case, you’ll have to 
create a second plane, entirely distinct from the original.

Setting up planes.

Once you’re satisfied with the planes, grab the Clone Stamp (fourth from 
the top), and Option + click the desired source (in our case, the barn door). 
Then clone the door onto the front-facing wall using the same method you 
would use with the normal Clone Stamp tool. Turn “Healing” on in the 
drop-down menu above the image preview to ensure that the source is 
properly blended into the destination.
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Vanishing Point result.

As you can see, Photoshop interpreted the planes fairly well. Some fine-
tuning and clean-up are definitely necessary if we want a believable image; 
but overall, the result is extremely impressive, given the lack of work 
required.

5 Quick Tips For Better Cloning

Now that we’ve examined each tool in depth, let’s close by recalling a few 
things to keep in mind if we want to clone with professional results.
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Take Your Time

As you undertake a cloning project, the quality of the result is directly 
proportional to the amount of time you put into it. Cloning photographic 
details can be incredibly tedious work. The world has become well 
acquainted with Photoshop magic, so never assume that no one will notice 
your blunders.

Duplicate the Active Layer

The very first step to take when cloning parts of an image is to duplicate 
the layer you’ll be working on (or to just work on a new transparent layer). 
Realizing that you made a mistake so long ago that your “Undos” don’t go 
back far enough to fix it is beyond frustrating. Keeping the original image 
on a hidden layer gives you the flexibility to revert any part of an image to 
its original state.

Be Selective With Your Tools

Each cloning tool has its strengths and weaknesses, as outlined above. 
Never arbitrarily grab a tool and stick with it for the duration of a project. 
Consider which tool is best suited to the particular area of the image you’re 
working on. On large projects, no single tool creates believable results on 
its own. Use two or more tools in synergy to achieve a realistic result.
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Watch for Obvious Duplication

Sloppy cloning results in noticeable patterns.

If you’re not careful, duplicated pixels can become painfully obvious. This is 
especially true of areas that should look fairly organic, like the grass above. 
Instead of appearing natural, an obvious pattern emerges when you use the 
same section of an image over and over. To avoid this, make heavy use of 
the Clone Source palette. Use multiple sources; and change the size, 
rotation and orientation of the areas you’re cloning to give the illusion of 
an unmanipulated image.

Avoid Disasters

When retouching significant parts of an image, overlooking certain areas 
becomes all too easy.
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Where did her leg go!?

If you’re not careful, you could eliminate enough vital body parts to make 
the image humorous. Your goal is to prevent your work from showing up 
on Photoshop Disasters, which is where you’ll find the image above.
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Conclusion

Cloning in Photoshop is a difficult task that requires significant time, 
studious attention to detail and an in-depth knowledge of several tools and 
commands. To improve the quality of your results, invest some time 
learning Photoshop’s entire cloning arsenal. Experiment with all of the 
options for each tool to get a better feel for where you can excel.
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Designing for iPhone 4 Retina Display: 
Techniques and Workflow
Marc Edwards

The iPhone 4 features a vastly superior display resolution (614400 pixels) 
over previous iPhone models, containing quadruple the 153600-pixel 
display of the iPhone 3GS. The screen is the same physical size, so those 
extra dots are used for additional detail — twice the detail horizontally, and 
twice vertically. For developers only using Apple’s user interface elements, 
most of the work is already done for you.

For those with highly custom, image-based interfaces, a fair amount of 
work will be required in scaling up elements to take full advantage of the 
iPhone 4 Retina display. Scaling user interfaces for higher detail displays — 
or increasing size on the same display — isn’t a new problem. Interfaces 
that can scale are said to have resolution independence.

In a recent article, Neven Mrgan described resolution independence: “RI 
[resolution independence] is really a goal, not a technique. It means having 
resources which will look great at different sizes.” If it’s a goal, not a specific 
technique, then what techniques exist? How has Apple solved the problem 
in iOS?

Fluid Layouts

While apps that take advantage of Apple’s native user interface elements 
require a lot less work when designing for the Retina display, we’re here to 
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talk about highly custom, graphic-driven apps that need a fair amount of 
work to take full advantage of the Retina display.

While not strictly a resolution-independent technique, using a fluid layout 
can help an app grow to take advantage of a larger window or screen by 
adding padding or by changing the layout dynamically. A lot of Mac, 
Windows and Linux apps use this method, as do some websites.

This is partially how Apple handled the difference in resolution from iPhone 
to iPad — a lot of UI elements are the same pixel size, but padded to make 
use of the extra screen real estate. The status bar is a good example of this. 
It works because the pixel densities of the iPhone 3GS and iPad are similar 
(163 ppi vs 132 ppi).

Fluid layouts work when the change in density is minor, but aren’t any help 
with the iOS non-Retina to Retina display transition (163 ppi to 326 ppi). 
The image below demonstrates what would happen if an iPhone app was 
simply padded to cater for the higher resolution display of the iPhone 4. 
Buttons and tap areas would be the same size in pixels, but half the physical 
size due to the higher pixel density, making things harder to read and to 
tap.
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Just-in-time Resolution Independence

Another approach to handling widely different resolutions and pixel 
densities is to draw everything using code or vector-based images (like 
PDFs) at runtime. Without trying to stereotype anyone, it’s usually the 
approach engineering-types like. It’s clean, simple and elegant. It lets you 
design or code once, and display at any resolution, even at fractional scales.

Unfortunately, using vector-based images tends to be more resource-
hungry and lacks pixel level control. The increase in resources may not be 
an issue for a desktop OS, but it is a considerable problem for a mobile OS. 
The lack of pixel level control is a very real problem for smaller elements. 
Change an icon’s size by one pixel, and you will lose clarity.
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Neven emphasizes in his article that:

“…it is simply not possible to create excellent, detailed icons which can be 
arbitrarily scaled to very small dimensions while preserving clarity. Small 
icons are caricatures: they exaggerate some features, drop others and 
align shapes to a sharp grid. Even if all icons could be executed as vectors, 
the largest size would never scale down well.”

Although here he is talking exclusively about icons, his description is apt for 
most UI elements. The decisions involved in scaling are creative, not 
mechanical. Vector-based elements aren’t suitable for all resolutions, if you 
value quality.
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Ahead-of-time Resolution Independence

The best quality results — and the method Apple chose for the iPhone 3GS 
to iPhone 4 transition — comes from pre-rendered images, built for specific 
devices, at specific resolutions: bespoke designs for each required size, if 
you will. It’s more work, but pre-rendering images ensures everything 
always looks as good as possible.

Apple chose to exactly double the resolution from the iPhone 3GS to the 
iPhone 4, making scaling even easier (different from the approach 
of Google and Microsoft — notice that this article is not relevant to the 
latest version of Microsoft’s mobile OS — proving yet again that controlling 
the entire stack has huge advantages).
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Currently, there are three iOS resolutions:

• 320 × 480 (iPhone/iPod touch)

• 640 × 960 (iPhone 4 and iPod with Retina display)

• 768 × 1024 / 1024 × 768 (iPad)

In a few years, it seems highly likely that the line-up will be:

• 640 × 960 (iPhone/iPod touch with Retina display)

• 1536 × 2048 / 2048 × 1536 (iPad with Retina display)

• Some kind of iOS desktop iMac-sized device with a Retina display

There are significant differences between designing iPhone and iPad apps, 
so completely reworking app layouts seems necessary anyway — you can’t 
just scale up or pad your iPhone app, and expect it to work well or look 
good on an iPad. The difference in screen size and form factor means each 
device should be treated separately. The iPad’s size makes it possible to 
show more information on the one screen, while iPhone apps generally 
need to be deeper, with less shown at once.

Building Designs That Scale

Building apps for the iPhone 4 Retina display involves creating two sets of 
images — one at 163 ppi and another at 326 ppi. The 326 ppi images 
include @2x at the end of their filename, to denote that they’re double the 
resolution.

When it comes to building UI elements that scale easily in Adobe 
Photoshop, bitmaps are your enemy because they pixelate or become 
blurry when scaled. The solution is to create solid color, pattern or gradient 
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layers with vector masks ( just make sure you have “snap to pixel” turned on, 
where possible). While a little awkward at times, switching to all vectors 
does have significant advantages.

Before anyone mentions it, I’m not suggesting any of the methods are new; 
I’m willing to bet that most icon designers have been working this way for 
years. I’ve been using vector shapes for ages too, but the Retina display has 
changed my practice from using vector shapes only when I could be 
bothered, to building entire designs exclusively with vector shapes.

I usually draw simple elements directly in Photoshop using the Rectangle or 
Rounded Rectangle Tool. Draw circles using the Rounded Rectangle Tool 
with a large corner radius, because the ellipse tool can’t snap to pixel. Layer 
groups can have vector masks too, which is handy for complex compositing 
(option-drag a mask from another layer to create a group mask).

More complex objects get drawn in Adobe Illustrator to the exact pixel size, 
and then pasted into Photoshop as a shape layer. Be careful when pasting 
into Photoshop, as the result doesn’t always align as it should — it’s often 
half a pixel out on the x-axis, y-axis or both. The workaround is to zoom in, 
scroll around the document with the Hand Tool, and paste again. Repeat 
until everything aligns. Yes, it’s maddening, but the method works after a 
few attempts. Another option is to zoom in to 200%, select the path with 
the Direct Selection Tool, and nudge once, which will move everything 
exactly 0.5px.
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Even more complex objects requiring multiple colors get drawn in 
Illustrator to the exact pixel size, and then pasted into Photoshop as a 
Smart Object. It is a last resort, though — gradients aren’t dithered, and 
editing later is more difficult.

If you need to use a bitmap for a texture, there are three options: use a 
pattern layer, a pattern layer style, or build a bitmap layer at the 2× size and 
turn it into a Smart Object. I prefer to use pattern layer styles in most cases, 
but be warned: patterns are scaled using bicubic interpolation when you 
scale the entire document, so they become “softer.” The solution is to create 
two versions of each pattern, then to manually change pattern layer styles 
to the correct pattern after scaling — a little tedious, but totally do-able 
approach.
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Scaling Up

At this point, your document should be able to scale to exactly double the 
size, without a hitch.
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I have a Photoshop Action set up that takes a History Snapshot, then scales 
to 200%. That means, previewing at the Retina display’s resolution is only a 
click away. If you’re feeling confident you’ve built everything well, you 
should be able to scale up, edit, then scale down and continue editing 
without degradation. If you run into trouble, a Snapshot is there to take you 
back. Using one document for both resolutions, means not having to keep 
two documents in sync — a huge advantage.
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A word of warning: layer styles can only contain integer values. If you edit a 
drop shadow offset to be 1 px with the document at 2× size, and then scale 
it down, the value will end up as 1 px because it can’t be 0.5 px (a non-
integer value). If you do require specific changes to the 2× version of the 
Photoshop file, you’ll have to save that version as a separate file.

Exporting, Exporting, Exporting

Now for some bad news: exporting all the images to build an app can be 
extremely tedious, and I don’t have much advice here to assist you. As my 
documents act as full screen mockups, they’re not set up in a way that 
Photoshop’s Slice feature is any use. Layer comps don’t help either — I 
already have folders for each app state or screen, so switching things off 
and on is easy.

The best export method seems to be: enable the layers you’d like visible, 
make a marquee selection of the element, then use Copy Merged and paste 
the selection into a new document — not much fun when you have 
hundreds of images to export.

The problem is amplified when saving for the Retina display, where there 
are twice as many images and the 1× images must match the 2× images 
precisely.
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The best solution I’ve come up with so far:

• Build your design at 1×

• Use Copy Merged to save all the 1× images

• Duplicate the entire folder containing the 1× images

• Use Automator to add @2x to all the filenames

• Open each @2x image and run the “Scale by 200%” Photoshop action. 
This gives you a file with the correct filename and size, but with 
upscaled content

• Scale your main Photoshop design document by 200%

• Use Copy Merged to paste the higher quality elements into each @2x 
document, turn off the lower quality layer, then save for the Web, 
overwriting the file

In some cases, Photoshop’s “Export Layers To Files” can help. The script can 
be found under the File menu.

Mac Actions and Workflows

All the Actions and Workflows that I use myself can be downloaded. The 
Automator Workflows can be placed in your Finder Toolbar for quick access 
from any Finder window, without taking up any space in your Dock.

Fortunately, Apple chose to exactly double the resolution for the iPhone 4, 
and for using ahead-of-time resolution independence. As complex as the 
process is now, things would have been far worse if they had chosen a 
fractional scale for the display.
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Mastering Photoshop: Pixel Perfection 
When Rotating, Pasting and Nudging
Marc Edwards

When creating Web and app interfaces, most designers slave over every 
single pixel, making sure it’s got exactly the right color, texture and position. 
If you’re not careful, though, some common functions like moving, rotating 
and pasting can undo your hard work, resulting in a blurry mess. But with 
some small changes to your workflow, you should be able to maintain the 
highest-quality artwork from the start to the end of the project.

Pixel perfect rotation
If you’re not careful, rotating layers in Photoshop can damage them in 
a very noticeable, pixel-mashing way.

When rotating layers with Free Transform (and some other tools) to exactly 
90 or 270°, the quality of the outcome is determined by the layer’s size. If 
the layer is of an even width and even height, then you’ll be fine. If it’s of an 
odd width and odd height, you’ll also be okay. But if they’re of an odd 
width by even height or even width by odd height, then you’ll see 
something like the result below:
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In this case, the artwork is 20 × 9 pixels: even-by-odd dimensions. The 
results for bitmap layers and vector layers are different, but they both 
produce unusable results because the origin of rotation doesn’t fall on an 
exact pixel boundary..

A Fix

Because even-by-odd or odd-by-even dimensions are the problem, we 
need a way to ensure that the contents of the layer are odd-by-odd or 
even-by-even. Probably any method you can think of will solve this 

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 127



problem, be it adding a square bitmap mask to a layer or adding more 
content to the layer that you’re rotating. You could also draw a square on 
another layer and rotate both at once.

As long as the dimensions for the layer or layers are even-by-even or odd-
by-odd, it’ll be fine.

An Easier Fix

Changing the origin of rotation to the top left (or any other corner) will 
ensure it is on a pixel boundary, guaranteeing perfect results every time. To 
do this, click on a corner origin after selecting the Free Transform tool, but 
before rotating. This works brilliantly and is the simplest solution yet.
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Bitmap and vector masks are affected by this issue as well, so please take 
care. But the issue affects only rotated layers, either via “Free Transform” or 
“Transform” under the Edit menu. Rotating the entire canvas via Image → 
Image Rotation has no problem.

Pixel Perfect Vector Pasting

If you’ve drawn pixel-snapped artwork in Illustrator and pasted it into 
Photoshop as a shape layer, you may have noticed that the result is not 
quite what you expect (i.e. a perfectly sharp image), but rather a blurry 
mess. Here’s how to fix that.

Below is some artwork as it appears in Illustrator: perfectly formed, 
snapped to the pixel grid, and at the size we intend to use it in Photoshop.

Below are the same paths pasted into Photoshop a few times. Notice how 
only the top-left version is sharp, while the others are half a pixel out on the 
x axis, y axis or both.
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What Went Wrong?

Photoshop’s pasting behavior works in one of two ways. If you’ve made a 
selection, then the clipboard’s contents are pasted so that the center of the 
clipboard is aligned with the center of the selection. If a selection hasn’t 
been made, then the contents are pasted so that the center of the clipboard 
aligns with the center of your current view. The level you’re zoomed into 
and the portion of the document you’re viewing determines the result.
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A Fix

Our test artwork is 32 pixels wide by 12 pixels high. Drawing a 32 × 12 
marquee selection in Photoshop forces the artwork to land exactly where 
we want it and to be pixel-aligned. This works every single time.

An Easier Fix

The marquee doesn’t have to be the exact size of your artwork, though. In 
our case, a 2 × 2-pixel selection would work just as well, because the center 
of an even-width-and-height marquee selection and the center of even-
width-and-height clipboard contents would fall exactly on a pixel boundary, 
which is what we want. If the artwork was an odd width and height, then a 
1 × 1 selection would have been required.

If you couldn’t be bothered noting your artwork’s dimensions, then by 
drawing an appropriately sized marquee, you can draw a 2 × 2-pixel 
selection and paste. If the image is blurry on the x axis only, make the 
selection 1 × 2 and paste again. If the image is blurry on the y axis only, 
make the selection 2 × 1 and paste again. If the image is blurry on both 
axes, make the selection 1 × 1 and paste again.
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It may sound complex, but in practice it’s very quick; you’ll only ever have 
to paste twice to get sharp vector paths from Illustrator.

Smart Objects

Pasting elements as smart objects doesn’t come with the same issue (at 
least not in Photoshop CS5 anyway). I like to use Shape layers, though: they 
allow more control and editability and have better anti-aliasing.

Pixel perfect vector nudging

When nudging vector points, Photoshop exhibits some strange behavior, 
related to how far you’re zoomed in. At 100%, nudging with the arrow keys 
will move your vector point exactly 1 pixel. At 200%, nudging moves the 
point by half a pixel. At 300%, it moves by a third of a pixel.

The behavior seems intentional, but it’s not usually what I’m after. Most of 
the time, I want to nudge in whole pixel increments. Here’s how you can do 
that, without zooming out to 100%.

Open your document, and then create a second window by going to 
Window → Arrange → New Window. You can then resize the new window 
and place it out of the way.
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Edit in the other window as normal, zooming in as far as you’d like. You’ll 
now be able to press Command + ` to switch back to the window that’s 
zoomed to 100%, nudge using the arrow keys, and then press Command + 
` to switch back again. Because the other window is zoomed to 100%, 
nudging will move the selected vector points exactly 1 pixel.
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Please note that holding Shift while using the arrow keys to nudge always 
moves by 10 pixels, no matter how far in you’re zoomed. Also, dragging 
points with the mouse will snap to pixels in most situations—most, but not 
all.

While not perfect, this technique does remove some of the frustration with 
editing detailed vector paths in Photoshop. Or maybe it’s just another 
reason why complex shapes should be drawn in Illustrator first, and then 
pasted as shape layers?

Take Charge Of Your Pixels

Using the correct techniques, it should be easy to place pixels exactly where 
you want. Remember, you’re the one in charge. Demand that they fall in 
line. Accept nothing less than pixel perfection.
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Setting up Photoshop for Web and iPhone 
Development
Marc Edwards

Most people who have designed websites or apps in Photoshop will, at one 
point or another, have had issues trying to match colors in images to colors 
generated by HTML, CSS or code. This article aims to solve those problems 
once and for all.

Color Management to Match Colors Across Multiple 
Devices

In the print world, color management typically involves calibrating your 
entire workflow, from scanner or digital camera to computer display to hard 
proofs to the final press output. This can be quite a tall order, especially 
when the devices use different color spaces – matching RGB and CMYK 
devices is notoriously hard.

When designing or editing for TV, calibrating the main editing display and 
using a broadcast monitor are common; these show real-time proof of how 
the image will look on a typical TV in a viewer’s home. In such a scenario, 
color management offers many benefits and is highly recommended.

When building Web and application interfaces, the situation is a little 
different. The final output is the same device that you’re using to create the 
artwork: a computer display (putting aside for now differences in gamma 
between Windows, Mac OS X prior to 10.6 and the iPhone, which we’ll 
cover later.)
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There is a catch, though. Even though you’re creating the Web or app 
interface on the same device that the final product will be shown on, the 
colors will have various sources: images (typically PNG, GIF and JPEG), style 
markup (CSS) and code (JavaScript, HTML, Objective-C, etc). Getting them 
all to match can be tricky.

The goal

When designing websites or app interfaces, we want to perfectly match the 
colors that are displayed on screen in Photoshop and that are saved in files 
with what’s displayed in other applications, including Firefox, Safari and the 
iPhone Simulator. Not only do we want the colors to look the same, but we 
want the actual values saved in the files to perfectly match the colors we 
have defined in Photoshop. Colors should not shift or appear to shift in any 
way, under any circumstance.

Why is this so difficult?

Photoshop applies its color management to images displayed within its 
windows and to the files it saves. This is a bad thing if you’re working 
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exclusively with RGB images for Web or on-screen user interfaces. With the 
default Photoshop settings, #FF0000 will actually display as #FB0018, and 
#BB95FF will display as #BA98FD. The differences are subtle but definitely 
there.

How Does Photoshop Differ from OS X and Windows?

OS X’s color management is applied to the entire display at the very end of 
the processing chain, after the main buffer in video ram. This means that 
although color management is applied, the software utilities that measure 
color on screen (like /Utilities/DigitalColor Meter) will report the same 
values that you have saved in the file or entered as your code. I believe the 
color management in Windows Vista and Windows 7 (Windows Color 
System) works in a similar fashion.

Photoshop’s color management is applied only to the image portion of its 
windows and to the files it saves. This color correction happens as 
Photoshop draws the image on screen, so software utilities that measure 
color on screen often report different colors from the ones you have 
specified. It’s worth noting that OS X’s color management is applied on top 
of Photoshop’s.

The best solution I’ve found is to disable Photoshop’s color management 
for RGB documents as much as possible. Doing so forces the RGB colors 
that are on screen and saved to the file to match the actual color value. If 
you need to calibrate your monitor for Web and app design work, then you 
would best be served by changing it at the OS level.

Disabling color management used to be quite easy in Photoshop CS2 and 
all versions prior, but it now requires a little more skill.
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Disabling Photoshop’s RGB Color Management

These instructions are for Photoshop CS5 on Mac and Windows. Setting up 
CS4 is very similar.

Step 1: Go to Edit → Color Settings and set the working space for RGB to 
Monitor RGB.

Step 2: Open a document and go to Edit → Assign Profile, then set it to 
Working RGB. This must be done for every single document you work on.

Step 3: Ensure View → Proof Colors is turned off.

Step 4: When saving files with Save for Web & Devices, ensure that Convert 
to sRGB is turned off. If you’re saving a JPEG file, then also turn off Embed 
Color Profile (you may want this turned on for certain photos, but chances 
are you’ll want it off for interface elements and icons).

Difference Between “Assign Profile” and “Convert To 
Profile”

Now would be a good time to mention the difference between Assign 
Profile and Convert to Profile, so that you know which to use when.

Each Photoshop document contains a color profile that’s separate from the 
actual color data stored for each pixel. Assign Profile simply changes the 
profile in the document, without affecting any of the color data. It’s a non-
destructive action: you can assign a new color profile to your documents as 
often as you like without doing any damage. Assigning a new profile may 
change the way your document appears on screen, but the data contained 
in the file will remain unaltered.
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Convert to Profile is quite different. Not only does it assign a color profile to 
the document, but it tries to keep your image looking the same on screen. 
It does this by processing the color data contained in the file for each pixel. 
Converting to a new profile will more likely preserve a document’s color on 
screen, but the data contained in the file will be permanently altered. Use 
with caution.

If you’re copying layers from one Photoshop document to another, you will 
want to ensure that the documents have been assigned the same color 
profile.

Illustrator is the Same as Photoshop

If you would like images saved in Illustrator or imported from Illustrator to 
Photoshop to match as well, then follow the steps below. These instructions 
are for Illustrator CS5 on Mac and Windows. Setting up Illustrator CS4 is 
very similar.

Step 1: Go to Edit → Color Settings, and set the working space for RGB to 
Monitor RGB.

Step 2: Open the document and go to Edit → Assign Profile. Then set it to 
Working RGB. This must be done for every single document you work on.

Step 3: Ensure that View → Proof Colors is turned off.

Step 4: When saving files with Save for Web & Devices, ensure that Convert 
to sRGB is turned off. If you’re saving a JPEG file, then also turn off Embed 
Color Profile (again, you may want this turned on for certain photos, but 
chances are you’ll want it off for interface elements and icons).
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Gamma Differences

Windows has used a gamma of 2.2 since its introduction. Mac OS X has 
used a gamma of 1.8 for all versions except Snow Leopard (the latest 
release), which uses 2.2. What does this mean? Prior to Snow Leopard, Web 
pages looked darker on Windows. Thankfully, both operating systems are 
now in sync, so a Web page should look very similar on a Mac and PC that 
use the same monitor.
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Final Check for iPhone UI

Your iPhone or iPod’s screen and calibration will likely be different from 
your Mac or PC’s screen and calibration. I often import full-screen images 
of the UI into iPhoto and sync them with an iPhone to see exactly how the 
final interface will look on the device (on Windows, you can sync photos 
using iTunes). This gives you another chance to make adjustments before 
slicing up images or committing anything to code.

This article explains how to handle the problem that while testing some 
landscape iPhone app interface mocks, they seem blurrier than they appear 
in Photoshop.

Please note: For some bizarre reason, the Photos app on the iPhone doesn’t 
display landscape images at 1:1. Instead, it scales them slightly or shifts 
them to a sub-pixel position, making the images blurrier than they should 
be. To avoid any issues, always save images in portrait mode (320 pixels 
wide by 480 pixels high) to test your user interface mockups.

Conclusion

Now, you’re able to move bitmap and vector images between Photoshop 
and Illustrator without any color shifts at all, and using any method. You’re 
also able to grab a color using the color picker in Photoshop, and then use 
the same HEX color value in your CSS, HTML, JavaScript, Flash or Objective-
C code, and it will match your images perfectly.
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Compositing in Adobe Photoshop: Time-
Saving Tips
Daniel Durrans

Compositing is a skill and process that spans the entire spectrum of creative 
industries. At the high end, compositing boasts its own specialized 
profession in film and television post production and visual effects. 
Dedicated software such as NUKE and Shake have taken the craft to 
powerful levels of its own, leaving behind the relatively basic compositing 
toolset of Adobe Photoshop. However, for many graphics practitioners 
compositing is a vital everyday process — and as with all pixel-pushing 
endeavors, Photoshop remains the entry point and hub to learning and 
ultimately mastering the fundamentals of this important skill.

In this article, I’ll share some of my own time-saving tips for compositing in 
Photoshop. Tips such as these should never replace a solid understanding 
of your craft; however, being able to adapt a technique to make it work for 
you is part of being a creative professional.

Tip 1: Matching Tones, Channel by Channel

One of the challenges we face when compositing is matching the colors 
and tones of various images to produce a realistic and convincing 
composite. This method aims to save you from spending time fiddling 
around with color balances and layers upon layers of adjustments, by 
showing you a systematic approach that should become second nature and 
enhance your compositing skill set.
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These are the three images we will composite together

In the following example, we will composite three people into one shot and 
address the differences in lighting, tone and color balance. I use this 
technique most often as a way of quickly grouping my subjects into a 
similar tonal range for further global color adjustments.
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Masked images placed on background

In the above image, I have masked out the images and placed them 
together on a background. (Read on for some time-saving tips on masking.)

The key to this technique is selecting one of the images as your target, and 
then matching the other two images to the tone and lighting of this target. 
Out of the three images, I like the colors, tones and contrast in figure 1 the 
most, so I’ve chosen it as our target.

Throughout this article, you will see that I am using Smart Objects. This is 
an excellent habit to get into when starting any Photoshop workflow. Smart 
Objects allow us to perform non-destructive transformations on a layer, as 
well as non-destructive filtering.
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Visual Evaluation

We are now entering the exciting world of greyscale tonal evaluation, deep 
inside the channels of our RGB image — the bare bones of bitmap imaging. 
We are going to go through each channel of the image and simply try to 
match the greyscale luminance levels to the target layer:

1. In the Channels palette, solo the red channel by either clicking the 
channel or using the keyboard shortcut Cmd/Ctrl + 3. You should see 
the entire image in greyscale, representing the luminance values of red.

2. Select the layer for figure 2 and add a Curves adjustment layer just above 
it. Make this adjustment layer a clipping mask by Alt/Opt clicking 
between the two layers in the layer palette. You could also select the 
adjustment layer and use the keyboard shortcut Cmd/Ctrl + Alt/Opt + 
G. Now select the red channel inside Curves.
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3. Now make a quick, overall visual evaluation of the two images: make a 
point right in the middle of your curve. If the mid-tones in your target layer 
(figure 1) look darker than your current layer (figure 2), move the midpoint 
down to darken the layer to better match your target. If the tones in the 
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target appear lighter than your current layer, move the midpoint up to 
lighten the layer and better match your target. Use small increments, and 
continuously use your eyes to evaluate the changes.

If things don’t look quite right still, locate the lightest shade of grey (but 
not white, as this could be a specular highlight — not something you want 
to factor in much, with compositing) on the target image, and do the same 
with figure 2. With your eyes darting between these two greyscale shades, 
move the white slider on the Curves dialog box until the shades visually 
match. Next, do exactly the same process with the darkest part of the 
image, moving the black slider in the Curves dialog.

Curves adjustments for the red channel
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4. Swap over to the blue channel, by either clicking the channel in the 
Channels palette or using the keyboard shortcut Cmd/Ctrl + 4. Select 
the blue channel within the Curves dialog box. Perform the same 
adjustment, starting by creating a center point on the curve, and dragging 
until the mid-tones in your image match those in the target.

Curves adjustments for the blue channel

5. Repeat these adjustments for the green channel. Click the green channel 
in the Channels palette or use the keyboard shortcut Cmd/Ctrl + 5.
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Curves adjustments for the green channel

6. You can now revert back to your RGB composite image by selecting the 
RGB channel in the Channels palette, or by using the keyboard shortcut 
Cmd/Ctrl + 2, and review the changes you have made. It is sometimes 
necessary to reduce the opacity of the adjustment layer if the change has 
been too drastic. Toggle the visibility of the adjustment layer to see a 
“before” and “after” for your adjustment. As we are using adjustment layers, 
our changes are non-destructive, so it is always possible to go back into the 
channels and curves to make further adjustments at any time.

7. Now, repeat steps 1–6 for figure 3, adjusting the curves per channel as 
before.
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(From left) “before” and “after” adjustments to figure 2

(From left) “before” and “after” adjustments to figure 3

The registered changes make an excellent starting point to a compositing 
task, providing the perfect platform for further color corrections and 
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adjustments. It is very rare that the image will be perfect at this stage, but 
the images will be more homogeneous and in a better relative condition to 
each other than before.

As you get more comfortable with this technique, start adding additional 
points to your curves by sampling tones from your image using the Curves 
sampler tool.

Tip 2: Gradient Map with Soft Light

Although this is not essentially a compositing technique, it is an especially 
useful adjustment to perform on a composited image, where the colors and 
tones often require this type of homogeneous tweaking and subtle 
realignment. This technique works well as a final adjustment to an image. It 
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has the effect of bringing all colors and tones slightly closer together, whilst 
still retaining their independence and relevance to the whole image.

1. Add a new Gradient Map Adjustment layer on top of all other layers. You 
will want to make sure that the layer thumbnail is selected, and not the 
layer mask thumbnail which is usually selected as default.

2. Next, turn off the visibility of the gradient map layer by deselecting either 
the eyeball next to the layer, or the eyeball at the bottom of the Gradient 
Map Adjustment panel.

Open a Gradient Map Adjustment layer, turning off visibility

3. Click on the gradient bar in the gradient map dialog box to open up the 
gradient editor. As default the gradient map is set to a black to white 
gradient — not particularly useful for this technique, but actually quite 
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handy at giving us an initial idea of the direction the dark to light tones we 
will select should be going in.

We are going to set ten points on the gradient bar — with colors picked 
directly from our image — going from darkest to lightest. First, click on the 
black point of the gradient and hover over the image; you should see the 
Eyedropper tool. Locate the very darkest point of your image and click; if it 
is black or very close to black, you won’t see much change in your gradient 
map. Now click just below the gradient bar, a small space away from the 
gradient point you just changed, to add a new gradient point.

Don’t worry about the distance between the points at this stage; we can 
change this at the end. Hover over your image again, select the next 
darkest area, and click. Continue with this process, adding progressively 
lighter points to the gradient bar all the way down to the white point, 
changing that to the lightest color in your image. You should aim to have 
ten points in total, although a few more or less is fine. Try to space out the 
points evenly before pressing OK.
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Sample ten colors from your image on the gradient bar

4. Turn on the visibility of the gradient map layer once more. You will 
probably see a frightening rendering of your carefully composited image, 
and you may be wondering now what you have just gone and done. Don’t 
worry; this is to be expected. Change the gradient map layer’s blending 
mode to Soft Light and reduce the opacity until you are happy with the 
image once more. Check the change by toggling the adjustment layer 
visibility on and off.
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Before

After
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Tip 3: Black & White Overlay

This is a great, quick trick for compositing that is perfect for those times 
when simply closing the job is a priority. The effect applies a stylized 
adjustment which tempers the colors in the image and increases contrast, 
especially useful in stylized shots such as sports imagery. The effect of the 
adjustment immediately makes the images more congruent, and this is 
what compositing is about.

1. Add a new Black & White adjustment layer above all layers you want to 
affect, and set the adjustment layer’s blending mode to Overlay.

Add the Black & White adjustment layer
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2. The great thing about the Black & White adjustment layer is the amount 
of control it gives you over the desaturation effect you have made. Adjust 
the color balances in the adjustment panel, and finally reduce the opacity of 
the layer to an effect you are happy with.

Final image with Black & White adjustment layer (set to overlay)

Compositing in Adobe Photoshop: Time-Saving Tips (2)

Tip 4: Lighting Direction

Often, one of the most difficult aspects of compositing is dealing with the 
direction light is coming from. Different images may be lit with the same 
intensity, with the same coloring and within the same tonal range, yet if the 
direction of the light is different, it can be fatal to the realism of the image.
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The images above will be composited into one shot with an efficient, non-
destructive way of addressing light directionality.

Masked images placed on background
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Once masked and placed on the background, we can see that the light on 
the two buildings is coming from opposite directions. We could flip one of 
the buildings horizontally, but this is often not an option in cases where we 
need to preserve the original angle and direction of an image.

Painting Shadows and Highlights

We will choose the light direction we wish to maintain, out of the two, and 
only work on the layer which we need to change. There are a multitude of 
methods for painting in shadows, so my main piece of advice is: do it non-
destructively. Try this method:

1. Add a new Curves adjustment layer above the layer you wish to affect. 
Make this adjustment layer a clipping mask by Alt/Opt clicking the line 
beneath the layer in the layer palette. You could also select the adjustment 
layer, and use the keyboard shortcut Cmd/Ctrl + Alt/Opt + G.

2. Make a point on the middle of the curve and move downwards to darken 
the layer. Fill the adjustment layer’s mask with black, and paint with a soft 
white brush into the layer mask to add shadow.
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Shadow added to building

3. Reduce the opacity until you are happy with the effect. You can always 
paint back into the layer, or use lower-opacity brushes, to get the effect just 
right.

4. To neutralize the shadow which exists on the wrong side of this same 
building, repeat the process by adding another Curves adjustment layer 
and setting it as a clipping mask. Add a mid point to your curve and move 
the curve upward to lighten the image. Fill the adjustment layer mask with 
black, and paint with a white brush over the shadow you wish to remove. 
Reduce the opacity quite a lot, until the shadow is no longer prevalent.

Of course the composited image is still nowhere near perfect, but that 
change in lighting has made a difference which now lets us imagine these 
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images could exist in the same world; that’s a great starting point for a 
compositing task.

Shadow is neutralized

Tip 5: Super-quick Previewing Using Blending Modes

Blending modes and tools offer a really powerful set of compositing 
features which can be used to speed up a lot of tasks. The following is a 
very simple trick which many people know about, but often forget.

Here is the scenario: you need to composite an image of a glass of milk on 
an image of a table.
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Sourced images for compositing

You have sourced the images you think would work together, and you need 
to check if the glass will sit realistically on the table, if the angles will line up 
and if the perspective will be convincing. However, you are so squeezed for 
time that even a rough trace of the glass would take too long. Luckily for 
you, the glass of milk has a black background.

Removing Black or White

Photoshop offers ready-made blending modes for removing black and 
white from one layer placed on top of another. The Multiply blending mode 
will render white pixels transparent, while the Screen mode does the same 
with black pixels. Both blending modes will also affect how other tones in 
your layer interact with the layer below, so unless this effect is something 
you are going for, this technique is usually best used to preview images 
which are on solid black or white backgrounds. This is massively time 
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saving, and is a great way of ensuring you are happy with the image before 
you commit to masking it out.

This can also help you when sourcing images for a time-sensitive task; 
knowing that solid black or white backgrounds can be so easily removed 
for previewing will help you identify the images most appropriate for your 
use.

Preview of how the elements fit, using only blending modes

Tip 6: Masking

Masking out an image is key to almost all compositing workflows, and is 
often the most time-consuming, tedious part. You have two main areas of 
masking to choose from when an image needs to be isolated from its 
surroundings. Manual masking is the preferred method of most top 
graphics professionals: usually this means using the pen tool, brushing in 
Quick Mask mode, or using the images channels to create an Alpha Channel 
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mask. Alternatively, automatic masking can be effected from an ever-
increasing range of tools and third-party plug-ins within Photoshop. Which 
method you choose will often be determined by how much time you have, 
the complexity of the task and the intended use of the image.

Rather than going through every masking technique (there are plenty of 
resources out there, if you want to learn about how each tool works), here 
is a quick run down of some time savers.

Quick Mask for Web Imagery

It might sound obvious as a time-saving trick, but when you need to mask 
an image in super-quick time, the Quick Mask really can be a life saver. I use 
it for Web imagery, as the edge details will then not be so apparent at the 
fixed pixel view the user will have. It is also important to choose an image 
with decent contrast between your masking subject and its background, or 
the Quick Selection tool will not do a great job with really tough selections.
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Quick Mask tool

Know Your Background Color

You can often save a lot of time masking, if you know and bear in mind 
what background your masked image will be composited on. Keep your 
goal in mind; when you need to get the job done, release your mind from 
the constraints of perfect masking and do the bare minimum!

Refine Edge

The Refine Edge tool set is a very powerful, non-destructive set of tools to 
help you refine any selection that is currently active. It can save you time, in 
fixing problem edges you may have encountered with other selection 
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tools. The values in the Refine Edge dialog box remain constant from one 
adjustment to the next, meaning this tool can also be great for ensuring the 
edges of composited images have the same level of softness, smoothing 
and contrast.

For Photoshop CS5 only: Photoshop CS5 has a time- and frustration-saving 
tool lodged inside its Refine Edge feature which can yield outstanding 
results. When it comes to masking fine details, every designer will tell you 
that hair is the most challenging. The Edge Detection tool allows you to 
identify the unwanted colors in your image while intelligently masking edge 
details; it can effectively identify the finest hair details and mask them out 
in a non-destructive dialog box, with minimal work on your part, and do a 
very convincing job.
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Refine Edge dialog box

Pen Tool

One thing I always do with the Pen tool, is keep a finger hovered over the 
Alt key; this is really useful as at any point, you can hold it down to move 
just one handle, and to freeze the corresponding handle in place. You can 
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also Alt-click any point on your path to toggle between a corner point and 
a smooth point.

Conclusion

There is no shortcut to becoming proficient on your chosen tool or in your 
chosen craft, be it Photoshop or anything else; but once you have mastered 
a tool and understand its power, it is then up to you to do what you do 
best: be creative with it. This means looking at those everyday tasks you do, 
the time limitations you are faced with and your ability to improvise. Look 
under the hood once in a while, and be creative and inventive with 
everything you do!
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Mastering Photoshop: Unknown Tricks 
and Time-Savers
Thomas Giannattasio

We all have shortcuts that are essential to our daily workflow. A majority of 
them are staples such as Copy (Command + C) and Paste (Command + V), 
but occasionally we stumble upon a shortcut we wish we’d learned years 
ago. Suddenly, this simple shortcut has streamlined our process and shaved 
quite a bit of time off our day. Collected here are some lesser known but 
extremely useful shortcuts. Many of these are not documented in the 
“Keyboard Shortcuts” menu, and some of them don’t even have equivalent 
menu options.

Please note that all of the shortcuts listed below assume that you are using 
Photoshop on OS X. They will work on the Windows platform by converting 
as follows: Command → Control and Option → Alt.

Layers

Selection

Sifting through nests of layer sets to find the layer you need quickly 
becomes tiresome. Luckily, there are a number of ways to select layers more 
intuitively. Using the Move tool (V), you can Command + click on the canvas 
to select the uppermost layer with pixel data located directly below the 
mouse. If your layers are grouped within layer sets, this action may have 
selected the entire folder. You can change this behavior to select the actual 
layer by using the Auto-select drop-down in the Move tool’s property bar.
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Changing auto-select behavior.

There will be times when you want to select a layer that is located below a 
number of other layers. By right-clicking with the Move tool, you’ll bring up 
a contextual menu containing a list of all layers located below the cursor. If 
your layers are properly named, you should be able to quickly select the 
layer you need. By holding Shift while using either of the selection methods 
above, you can select multiple layers. After selecting multiple layers, you 
can link the layers together by right-clicking and selecting Link Layers.

Right-clicking to display all layers beneath the cursor.
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The keyboard can also be used to select layers. Pressing Option + [ or 
Option + ] selects the layer below or above the current layer, respectively. 
Pressing Option + < selects the bottommost layer, and Option + > selects 
the uppermost. Option + Shift + < selects all layers between the current 
layer and the bottommost layer, and Option + Shift + > selects all layers 
between the current and uppermost.
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Sorting

Sorting layers with the mouse can be clumsy and slow. A few shortcuts 
speeds up the organizing. Command + [ and Command + ] moves the 
selected layer up or down one position in the stack. If multiple layers are 
selected, they’ll move relative to the uppermost or bottommost layer. 
Pressing Command + Shift + [ or Command + Shift + ] brings the selected 
layer to the top or bottom of its current layer group. If the layer is already at 
the top or bottom of the layer group, it jumps to the top or bottom of the 
parent layer group.
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Viewing

Option + clicking the eye icon of a layer is a commonly known way to hide 
or show all other layers. There is also a way to expand and collapse layer 
groups: by Command + clicking the arrow next to the layer group, you can 
close or expand all other layer groups; this does not work on nested layer 
groups. Alternatively, right-clicking the arrow gives you a menu to perform 
the same actions; but this will work on nested layer groups.
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Duplicating

There are a number of ways to duplicate data from one layer to another. 
Duplicating an entire layer is as simple as pressing Command + J. If a 
selection is active, you can use the same shortcut (Command + J) to create 
a new layer based on the selected area of the original layer. Pressing 
Command + Shift + J with a selection creates a new layer while cutting the 
data from the original layer. Holding Option while pressing one of the arrow 
keys allows you to duplicate the current layer and nudge it by 1 pixel. 
Holding Shift and Option nudges the new layer by 10 pixels.
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Duplicating data from multiple layers can also be done more quickly using 
some keyboard commands. Using Command + Shift + C with an active 
selection copies the data contained within it to the clipboard. You can then 
paste it to a new layer (Command + Option + Shift + N, Command + V). If 
you’d like to create a flattened copy of the entire document, use the 
shortcut Command + Option + Shift + E: a composite of all visible layers 
will be added as a new layer to the top of your layer stack.

Brushes

Shape and Size

Being able to quickly adjust the brush tool is crucial to getting a swift 
workflow. Many know about using [ and ] to decrease and increase the 
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brush’s diameter, as well as Shift + [ and Shift + ] to decrease and increase 
the brush’s hardness. However, CS4 introduced an even more intuitive way 
to do this. By holding Control + Option and dragging on the canvas, you 
can change the brush’s diameter with a visual aid. Control + Command + 
Option and dragging gives you control of the brush’s hardness.

The on-canvas drag makes brush adjustments more intuitive.

If you would like to completely change the brush shape to a different 
preset, press < or > to cycle through them and Shift + < or Shift + > to 
select the first or last brush. Right-clicking inside the canvas also displays a 
condensed menu of brushes.
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Opacity, Flow and Mode

The opacity of the brush tool can be quickly tweaked using the number 
keys: 3 = 30%; 3 + 5 = 35%; 0 + 3 = 3%; 0 = 100%. Holding Shift when 
inputting the numbers sets the flow of the tool. Note that if Airbrush mode 
is on, these two shortcuts swap (i.e. holding Shift controls opacity instead of 
flow). You can toggle Airbrush mode on and off using Option + Shift + P. 
The same numeric input method can be used to determine the opacity of a 
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layer when the Move tool (V) is active; pressing Shift allows you to alter the 
Fill of the layer.
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Quick Fill

Instead of selecting the Fill tool (G), you can quickly bring up the Fill menu 
using Shift + F5. Even better, bypass the menu entirely using Option + 
Backspace to fill with the foreground color or Command + Backspace to fill 
with the background color. These keyboard commands can also be used to 
quickly set the color of a type or shape layer. To preserve transparency 
when filling, you could first lock the transparency of the layer by pressing / 
and then fill, but there’s an easier way. Pressing Option + Shift + Backspace 
or Command + Shift + Backspace fills with the foreground or background 
color while preserving transparency.
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Pressing Command + Shift + Backspace to preserve transparency while filling.
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Blending Modes

You can cycle through blending modes or jump to a specific one by using 
just the keyboard. By pressing Option + Shift + (+) or Option + Shift + (-), 
you can cycle forward or backward through available modes. Alternatively, 
you can set a specific mode using the shortcuts below.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 184



Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 185



Typesetting

Setting type is a delicate and time-consuming process, but shortcuts speed 
it up. First off, hiding the inversed block that is created by selecting text is 
extremely beneficial. Command + H allows you to toggle the visibility of 
both the highlight and baseline stroke, making it easier to see the final 
result. When finished editing your text, you can commit changes by 
pressing Enter on the numeric keypad or Command + Return. Pressing Esc 
discards changes.
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Variants

There are six shortcuts for changing the font variant, but they should be 
used with caution. If the appropriate variant or character does not exist 
within the currently selected font family, Photoshop creates a faux variant. 
These fake variants are frowned upon within the typosphere and are 
extremely easy to spot. So, if you use these shortcuts, make sure that 
Photoshop has selected an actual variant and not faked it. Now, onto the 
shortcuts:
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Justification

To set the justification, use one of the commands below. Note that a 
selection must be made within the target paragraph for these to work.
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Spacing and Sizing

Properly sizing and spacing type is a tedious task, but Photoshop does 
provide some handy—albeit broad—shortcuts. Unfortunately, there is no 
way to fine-tune the increments by which they adjust. Note that these 
shortcuts will work only if a text selection is made; selecting a type layer is 
not enough. To change the type size by increments of 2, press either 
Command + Shift + < or >. To bump the increment up to 10 points, use 
Command + Option + Shift + < or >. Leading can also be modified by 2 or 
10 point increments using Option + Up or Down arrow or by Command + 
Option + Up or Down arrow.
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The arrow keys can also be used to adjust kerning and tracking. Pressing 
Option + Left or Right either kerns or tracks 20 units depending on whether 
or not a type selection is active (i.e. if the cursor is between two characters, 
kerning is applied; if multiple characters are selected, then tracking is 
adjusted). The increment can also be changed to 100 units using Command 
+ Option + Left or Right arrow. Finally, the baseline can be shifted by 2 or 
10 points using Option + Shift + Up or Down arrow or Command + Option 
+ Shift + Up or Down arrow, respectively.
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Resets

Sometimes, we have to return to the defaults. Below are some shortcuts to 
get you back on track.
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Mastering Photoshop: Unknown Tricks and Time-Savers (2)

Menus

Hidden within many of Photoshop’s menus are a number of shortcuts that 
make adjustments faster and easier. Just about every menu—whether for 
Adjustment, Filter or anything else—allows you to revert to the original 
settings; by simply holding Option, the Cancel button will turn into a Reset 
button. Depending on the menu, holding Option might even change some 
of the other buttons (e.g. the Done button in the “Save for Web and 
Devices” menu will change to Remember). Certain menus, such as the Filter 
Gallery, also allow you to hold Command to turn the Cancel button into a 
Default button.
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Using modifier keys to uncover in-menu options.

Spring-loaded Commands

By default, most menus transform the cursor into the Hand tool or Move 
tool. These tools can be used on the canvas while the menu is open to pan 
the document or to adjust settings, such as the Angle and Distance settings 
for a Drop Shadow. More tools, however, are available via spring-loaded 
shortcuts. The zoom tools can be accessed using either Command (to zoom 
in) and Option (to zoom out) or Command + Space (to zoom in) and 
Command + Option + Space (to zoom out). The hand tool can also be 
accessed by holding the space bar.
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Holding Command + Spacebar to access the zoom tool within the Blending 
options.

Adjustment Menus and Layers

The Curves adjustment, like most other adjustments, contains some handy 
shortcuts. Similar to how you can cycle through the Channels in a 
document, you can cycle through the adjustment’s channels using Option + 
2, 3, 4, 5, etc. You can also cycle through the points on the actual curves 
using - and =. With a point selected, you can nudge the points in 
increments of 2 in any direction using the arrow keys. Holding Shift in 
conjunction with the arrow keys moves the point by 16 units. When 
working with an adjustment menu, you can toggle the Preview option on 
and off by pressing P. Adjustment layers don’t have a Preview option, but 
you can temporarily disable it by pressing and holding \.
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Summary

Hopefully, reading this has taught you a few new tricks and uncovered for 
you some of the more obscure options within Photoshop. While 
memorizing shortcuts can be a chore, integrating them into your daily 
workflow saves you an incredible amount of time.
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Preparing Photoshop Files for Web 
Developers
Brian Rhinehart

Whether you’re a freelance Web designer or part of a team at an agency, 
handing off Photoshop files to a client, developer, development team or 
even another designer is part of the process of building websites.

Whereas the development process is generally more structured, by 
contrast, the design process is quite often spontaneous and full of 
experimentation. This can lead to a host of unused and unnamed layers 
that don’t end up as part of the final approved design. For developers, 
sifting through a quagmire of unnamed layers (Layer 1, Layer 1 copy, etc.) 
can be confusing and time consuming.

Designers can help their counterparts or clients before the design hand-off 
by taking 10 to 15 minutes to prepare files in a consistent and organized 
manner that can potentially save developers hours of production time. As 
an added bonus, an organized Photoshop file will save designers time by 
minimizing development questions after the file has been handed off for 
coding.

1. Prepping the File

First and foremost, make a copy of the Photoshop file that contains the 
approved design and add the suffix -prod to the file name. This way you 
can recognize a production file immediately and know that this file type is 
for development use only and not for further design refinements.
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Guides and layout

Properly align and remove any unnecessary guides in the document. Keep 
guides to a minimum and only section off the major regions of the layout 
by outlining blocks of page content such as the masthead, content area, 
sidebar and footer so that the developer understands what basic structure 
the page should follow. Keeping the number of guides to a minimum also 
allows the developer to then add guides where needed to aid them in 
visually mapping out layout details in the code such as nested divs and 
navigation menus.

Include a color palette

Create a layer group with its visibility turned off at the top of the Layers 
panel named “Palette.” Populate this group with layers using Layer > New 
Fill Layer > Solid Color… which are named to correspond to elements that 
will be colored using CSS. This allows developers to simply Double+click 
the layer thumbnail to get the color values they need from the Color Picker 
while coding.
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The added “Palette” Layer Group.

2. Navigation and Button States

During the design process, it’s easy to overlook that navigation graphics 
should have at least three states of user interaction that will need to be 
defined in a stylesheet. Place each state on its own layer and name that 
layer to correspond to its function. As an example, using the following for 
the layer names of a top navigation element (topnav, topnav:hover, 
topnav:active) will help to establish a common naming convention and 
language that both the designer and developer mutually understand and 
recognize.

Create sprite groups of navigation or button layers or layer groups to 
ensure that what you envisioned as a designer will get executed in the 
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code. Position the default state as the topmost layer within the group with 
the hover and active states below.

When creating sprite groups, it is also recommended that a consistent 
height be used for all of the states so that it is easier for the developer to 
calculate the background-position of the elements while coding the 
CSS.

Sprite groups showing the different navigation states.

3. Flattening Artwork

The purpose of flattening artwork is to preserve the approved design and 
to combine multiple layered elements into single layers that are more 
readily digested. Examples of this would be a base layer which is being used 
as a clipping mask and the secondary layers that are being clipped by that 
base layer, photomontages or a group of layers that comprise the 
background of a site.
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Merging layers

Merge (Command+E) layers and layer groups that won’t require further 
editing by the developer. This not only reduces the visual impact of the 
Layers panel, providing a clearer road map for the developer, but also 
removes the chance of design elements getting accidentally altered during 
image slicing.

Fonts

Web safe fonts that are used for headings and copy should be left as 
editable text. This allows developers to easily check the Character panel to 
see what values need to be applied to font properties in the stylesheet.

In cases where image substitution is to be used for items such as navigation 
or stylized text treatments, flatten the type layers just in case the developer 
doesn’t have a specific font available to them. Another method of 
preserving the appearance of a font would be to use Layer > Type > 
Convert to Shape in cases where the developer may need to resize a type 
treatment.

Smart objects

Smart objects are invaluable during the design process. They allow for 
resizing and styling with Smart Filters while remaining completely editable. 
However, once a design is approved these layer types should be rasterized 
or merged with other layers to reduce the overall file size as smart objects 
can often contain photos or other artwork that have a higher resolution 
(e.g. 300dpi) than is required for the final output of 72dpi. Another reason 
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to flatten smart objects is to prevent a “File Not Found” error message 
should the developer Double+click the smart object layer thumbnail.

4. Organizing the Layers Panel

First things first, clean house. This means deleting any layers that are empty 
or are not going to be used in the final design, especially all the duplicated 
layers that were used to test ideas during the creative process. By doing a 
little housekeeping you have already made the file easier to read.

Name all layers

Once you have flattened and merged all the layers that will not require 
editing, go through and name all of the layers and layer groups. Use a 
naming convention that is not only well recognized, but also common to 
your work environment. One example would be to assign layers names that 
correspond to the CSS that would be used for that layer such as 
“button:hover.” The point is to establish and maintain the nonverbal 
communication between the designer and developer through common 
practices and language.

Use layer groups

Group like elements into consistent layer groups. For example, when 
designing a WordPress theme, it would be logical to have layer groups with 
the names “Header,” “Content,” “Sidebar” and “Footer.” It’s also good 
practice to group like items that constitute a navigational element or other 
design elements that have multiple states such as icons, buttons and 
menus.
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Mirror the layout

Start from the top of the page layout and work your way to the bottom, 
arranging the layers and layer groups in descending order to correspond 
with their position in the design. In this manner a developer can quickly 
scan through the layer names to identify where a particular design element 
is located within the Layers panel based on its visual location in the design. 
This is especially helpful should they need to isolate it for editing or slicing.

Use nested layer groups that reflect the hierarchical structure of the layout. 
A layer group called “Sidebar” might contain layer groups “search” and 
“advertising.” Nested layer groups can also illustrate to the developer how 
elements are arranged structurally within the HTML.

5. Handing off the PSD

When the file has been prepared, don’t just send the file in an e-mail or 
upload it to the development server. Schedule a hand-off meeting and take 
the time to go over the file(s) with the developer to ensure that they have a 
firm understanding of how the end product is supposed to not only look, 
but behave in terms of user interaction. In the end, both designers and 
developers will save valuable time.
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In Defense of Photoshop
Thomas Giannattasio

Waves of change are currently rippling through every aspect of the Web. 
The iPad and other mobile devices are changing the way we access the 
Internet, while HTML5 and CSS3 promise to change the way we develop it. 
However, another storm is brewing that threatens Photoshop’s throne as 
the application of choice for Web design. The battle suggests a 
fundamental shift in the design process from Photoshop to mark-up.

A militia of designers have assembled to launch this coup. Their 
propaganda is convincing, and their proposed successor is worthy, capable 
and sexy. Their cause is important, but their manifesto is flawed.
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The Argument

The argument against Photoshop focuses on the effect of the final product. 
Photoshop can be used to create impeccable designs, but after hours of 
hard work, you end up with a static mock-up that is incapable of emulating 
the experience one gets when the design is converted to mark-up and 
viewed in the browser. HTML and CSS mock-ups require no explanation. 
They present the final product in the final environment. They also take full 
advantage of browser capabilities, such as fluid layouts, progressive 
enhancement and animation. These are things that Photoshop simply can’t 
do.

If we compare the two methodologies even closer, we find a number of 
other disadvantages to the Photoshop approach. For example, Photoshop’s 
text rendering is nothing compared that of modern Web browsers. CSS 
classes also make the process of updating similar elements easier than 
hunting down all instances within a Photoshop document. Even making 
certain structural changes to a website can be done more easily with CSS. 
Finally, I can’t overlook Photoshop’s propensity to crash, especially when 
opening the “Save for Web” dialog.

I admit: the benefits of mark-up are undeniable, and Photoshop doesn’t 
offer any of them. In fact, the mark-up generated across the entire Creative 
Suite is rather atrocious and unusable. Why then do I think Photoshop is 
still the most important Web design tool available today? The answer lies in 
the creative process.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 207



Process Makes Perfect

The creative process is exactly that: a process. Clients may think we simply 
snap our fingers to make creative goodness flows directly from our brains 
to the screen, but we know better. We know that it takes hours or days of 
deep thought to devise the perfect solution. And if you’re anything like me, 
you often don’t find the perfect solution until you’ve explored a number of 
dead ends. Essentially, we need time and experimentation to work towards 
the goals of a project and determine the best way to communicate what 
needs to be said.

Experimentation is the key to creativity. Without it, the brain simply follows 
what it regards as the safest route, and the result is as mundane as the 
thought behind it. Most of the designers I know start all of their designs on 
paper: creating thumbnail sketches in order to quickly experiment with 
possible solutions. However, these sketches serve as jumping-off points; the 
design process is by no means over once the pencil is traded for mouse 
and keyboard.

Photoshop is vital to good Web design because it extends the process that 
was started on paper. It gives stakeholders a direct connection to the 
visuals without regard for the technical execution of the product. In other 
words, it accommodates visual processing. The designer is given a blank 
canvas—a playground for experimentation—on which anything is possible.
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As designers, our medium is in a visual language. It’s a language of the 
subconscious, and it allows us to connect to other people through our work 
in ways that the spoken word cannot. Great design relies on an open 
dialogue between the artist and the medium. Interfering with that dialogue 
only impedes the process and distorts the message.

Designing with mark-up, however, creates a disconnect with the medium. 
Ideas no longer flow fluidly onto the screen. They must first be translated 
into a language that the computer understands. Like a game of telephone, 
this methodology requires a great deal of interpretation, which inevitably 
dilutes the idea and its potency. This chain of translation introduces a 
latency that kills experimentation and compromises the design.
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The Foreman Or The Architect

Truth is often seen clearer in extremes. So, let’s try a little thought 
experiment. Imagine yourself as an architect tasked with designing a large 
corporate skyscraper. How would you proceed? If you’re like most 
architects, you would start by sketching, and then work your way into 
AutoCAD. Eventually, you’d end up with a computer-generated 3-D model. 
You’d probably take it even further by constructing a small-scale model. All 
of this processing gives you a better feel for the project without actually 
building it. It’d be preposterous for the architect to go out and start 
welding I-beams together as part of his design process; that is the 
foreman’s responsibility, and construction begins only once everything has 
been designed.

Designing with mark-up is like welding I-beams without a blueprint. The 
client understands—or should understand with your help—that the mock-
ups are not the final product and that this actually benefits them. They want 
to get an idea of what the website will look like without having the entire 
thing built first. It allows them to change the direction of the project before 
investing too much. Our responsibility is to explain the differences between 
the mock-up and the final product. Moral of the story: don’t play foreman 
when you’re the architect.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 210



A Call To Arms

Although mark-up can provide a truer experience for clients, Photoshop is 
clearly an important part of the design process. Ridding it from our toolbox 
could prove disastrous. What we need is not to change our methodology, 
but rather to amalgamate our tools. We need a tool that supports the 
creative process but at the same time gives us access to the subtleties of 
our medium.

Modern WYSIWYG editors are off the mark. We need something more like 
Photoshop, but with capabilities that allow us to create DOM elements as 
easily as we can create shapes. John Nack seems to be on the right track 
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with his idea of HTML layers, which would enable users to create and style 
HTML elements and render them with the WebKit engine all within a 
standard PSD file. While this idea is not completely practical, it gives us 
something to work with. Imagine opening the layer styles dialog and being 
able to add CSS3 styling to an element. What bliss!

An example of what HTML layers might look like with CSS styling.

Jeffrey Zeldman makes a number of valid points about why creating such a 
tool is impossible:

HTML is a language with roots in library science. It doesn’t know or care 
what content looks like. (Even HTML5 doesn’t care what content looks like.) 
Neither a tool like Photoshop, which is all about pixels, nor a tool like 
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Illustrator, which is all about vectors, can generate semantic HTML, because 
the visual and the semantic are two different things.

I have to agree. Any tool that is meant to translate visual elements from 
canvas to code will inevitably fail in the semantic realm. Computers are 
monolingual: they need us to make that translation. However, do we need 
perfectly semantic code if we’re only creating a mock-up? Why can’t we 
accept the reality that we’re not crafting the final product and simply spit 
out HTML and CSS that’s “good enough” for mock-up purposes. Once the 
design is approved, we’ll put on our foreman hat and begin the real 
construction.

Until our paradigm is rocked by some killer new app, Photoshop will reign 
as the best tool for designing websites. Although it doesn’t currently speak 
to our medium the way we wish it did, it proves itself priceless when it 
comes to the process of designing. Photoshop is a virtual playground of 
experimentation; dropping it from the process only prevents your design 
from being fully developed. So, before you switch to the mark-up 
methodology, understand that you’re sacrificing creativity for a few browser 
capabilities, which could be explained to clients anyway. For the sake of 
your client, creativity and work, stick with Photoshop.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 213



The Authors
Brian Rhinehart

Brian Rhinehart is a freelance designer and illustrator who has been 
working in the media and design industry for the past seventeen years. 
When he’s not working for clients, he spends his time illustrating or 
engaging in other personal artistic ventures.

Daniel Durrans

Daniel Durrans is a designer and illustrator from London, now living in 
Malta. He is an Adobe Certified Expert in Photoshop and writes on subjects 
from across the creative industries.

Dirk Metzmacher

Dirk Metzmacher is a professional Photoshop trainer and book author with 
over 10 years of experience. He is also the creative mind behind 
Photoshop-Weblog (www.photoshop-weblog.de), a blog about techniques, 
tutorials and resources related to Adobe Photoshop.

Joshua Johnson

Joshua Johnson is a Graphic Designer/Web Designer with several years of 
experience working with major international marketing agencies. He is also 
the Editor of Design Shack, a web design and development blog.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 214

http://kineticshadows.com/
http://kineticshadows.com/
http://www.ddurrans.com/
http://www.ddurrans.com/
http://www.photoshop-weblog.de/
http://www.photoshop-weblog.de/
http://designshack.co.uk/
http://designshack.co.uk/


Marc Edwards

Marc Edwards (@marcedwards) is the Director and Lead Designer at Bjango 
(@bjango), an iOS and Mac app developer. Marc has been using Photoshop 
and Illustrator for over 12 years, designing for print, Web, desktop 
applications and iOS.

Thomas Giannattasio

Tom Giannattasio is the Art Director at the creative agency nclud. His 
personal portfolio can be viewed at attasi.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 215

http://twitter.com/marcedwards
http://twitter.com/marcedwards
http://bjango.com/
http://bjango.com/
http://twitter.com/bjango
http://twitter.com/bjango
http://www.nclud.com/
http://www.nclud.com/
http://www.attasi.com/
http://www.attasi.com/


The Smashing Shop

Feel free to check out more of our eBooks in the Smashing Shop.

Smashing eBook #8│Mastering Photoshop for Web Design, Volume 2 │ 216

http://shop.smashingmagazine.com
http://shop.smashingmagazine.com

